Krell KSA-50 problems - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th December 2007, 01:18 PM   #1
legarem is offline legarem  Canada
diyAudio Member
 
legarem's Avatar
 
Join Date: Jan 2005
Location: Quebec city
Default Krell KSA-50 problems

Hi

One of my friends has an original Krell KSA-50. There was a contact problem with the heat protection sensor.

After repairing the bad sensor contact, I decided to look at the square waves on both channels.

When feeding the amp with a 20khz square wave, I had a big surprize. I never saw something so bad as what I saw on both channels square waves.

This amp seems to oscillate or it is really sick. Placing a 1uF in parallel with the load shows that it doesn't like capacitive charges at all.

As this amp was made in 1983, someone told me that the output transistors and the power supply caps are worn.

What is the problem. On the picture, you see 20khz square wave with 8 ohm load. Both channels are showing that.
Attached Images
File Type: jpg krellksa50.jpg (9.1 KB, 171 views)
  Reply With Quote
Old 8th December 2007, 07:43 AM   #2
djk is offline djk
diyAudio Member
 
djk's Avatar
 
Join Date: Feb 2001
Location: USA
Classic look of the high-pass output of a crossover.

http://www.diyaudio.com/forums/attac...amp=1097958247

(note the collectors of the Vas must be connected to the base of the drivers)

If C4 or C5 dry up (very common), amplifier will go to unity gain at low frequency. It will have normal gain above the pole set by C3/R9 (probably 3Khz~5Khz).
__________________
Candidates for the Darwin Award should not read this author.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Krell Audio Video Standard Problems gto127 Digital Source 0 11th July 2009 05:13 AM
Problems with Krell sacd ingemar Digital Source 4 14th August 2007 03:13 PM
Krell KSA 100 Alex helge Solid State 2 24th February 2003 03:05 AM


New To Site? Need Help?

All times are GMT. The time now is 09:07 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2