Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th November 2007, 01:24 AM   #1
elshout is offline elshout  United States
diyAudio Member
 
Join Date: Jul 2006
Default Hafler DH500 help

I just purchased two Hafler DH-500 amplifiers. One is working and the other is not. I am a long-time audio buff but new to electronics.

All of the fuses are good. Here is what I have noticed. When I power up the working amp, the fan comes on, then a few seconds later I hear a click (sounds like it comes from near the power supply). On the non-working amplifier, the fan comes on, but I never hear a click.

Can anyone help? still4given, are you still out there?

I think it may be the 48 volt relay. Can someone give me very specific directions for checking this. I have a volt meter. Again, remember to be basic as I am new to electronics.

It it does turn out to be the 48 volt relay, does anyone know where to get this item. I saw one on ebay being sold by soundvalves. I missed the auction but emailed soundvalves. No response. It looks as though soundvalves is not very good at responding according to some of the post I have seen on this forum.

Thanks
Scott
  Reply With Quote
Old 20th November 2007, 11:37 AM   #2
d3imlay is offline d3imlay  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Ohio
the relay doesn't pull in because there is most likely DC on the output. If fuses aren't blown you likely have a driver board problem. If fuses are blown you have a bigger problem because the fets are long ago obsolete. Get a meter and check for DC going into the relay.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hafler DH-500 problems... ugh! DH500 nifaron Solid State 7 11th November 2008 06:25 PM
Hafler DH500 humm, internal wiring, and other questions alex333 Solid State 4 18th April 2008 02:00 AM
Hafler DH500 ebay incomplete, parts Mattyo5 Swap Meet 0 16th February 2008 01:35 PM
Hafler DH500 DC Offset LHMAudio Solid State 2 27th January 2007 10:00 PM
Hafler DH500 Heatsinks - looking for djk FBsHT Solid State 0 10th November 2006 03:47 PM


New To Site? Need Help?

All times are GMT. The time now is 02:01 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2