NAD C 320BEE Sound going out - seeking experience - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th November 2007, 03:19 AM   #1
diyAudio Member
 
Join Date: Apr 2002
Location: Baltimore
Default NAD C 320BEE Sound going out - seeking experience

I bought my NAD C320BEE about 2 years ago and it has been great (even with abuse) until now.

Recently I have had a problem getting the unit to play. I power it up, and press a (there are several, each with there own status LED) source button. The power light and source light both turn green like normal, but only for about 2 seconds, when the power light changes to red and any sound that was playing switches off. There is an audible pop from the speakers when the amp accepts the source (which didn't happen when the unit worked properly) and when the source is rejected (and the power light turns red). Between pops, the 2 seconds or so when everything seems normal, music can be heard normally.

Does anyone have any experience with this problem? I tried everything obvious to me short of opening it up... different speakers, different wall jack, different sources, tested speaker cables and they're fine. Since sound actually does come through during the two seconds the unit powers up it makes me suspect some kind of 'smart' shut-down circuit malfunction. Any help would be GREATLY appreciated.

Cheers,

Andy
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAD 320BEE for sale mravlcax Swap Meet 4 18th January 2009 07:55 PM
novice seeking help in building a sound system Snapshot Multi-Way 10 25th December 2008 10:48 AM
Experience on measuring sound cad transfer function? NIC1138 Digital Source 1 7th June 2007 03:09 AM
Nad 320Bee nning hot. Help!! sachi Solid State 1 2nd March 2005 12:56 AM
Anyone have experience diy prism sound and weiss DAC? bmpa Digital Source 2 16th April 2004 08:26 AM


New To Site? Need Help?

All times are GMT. The time now is 05:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2