TRIO / KENWOOD L-05M Monoblocks Repair Thread - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st July 2007, 04:19 PM   #1
poynton is offline poynton  United Kingdom
diyAudio Member
 
poynton's Avatar
 
Join Date: Mar 2005
Location: A life on the ocean waves when I'm not at home in N. Wales (but I'm not Welsh so no sheep jokes!)
Default TRIO / KENWOOD L-05M Monoblocks Repair Thread

Hi.

I have just been given a pair of these by Coliny from Derby, UK.

One is faulty with DC on the output, the other is fine.

As they are both in excellent condition for their age, I intend to repair them (if possible) and to document the repair.

I have the circuit diagrams.

The first thing is to obtain a source for the output transistors which are a 'special' type - 2SC2337 and 2SA1007.

These are described as 'Emitter-Ballasted Transistors' (EBT's).

Has anyone else any experience of these amps?


Andy
  Reply With Quote
Old 2nd August 2007, 06:13 AM   #2
diyAudio Member
 
WALTER BURKHARD's Avatar
 
Join Date: Dec 2002
Location: Helsinki
Default spare parts

http://eshop.euras.com/geraetesuche....00&login=25808
  Reply With Quote
Old 2nd August 2007, 06:15 AM   #3
diyAudio Member
 
WALTER BURKHARD's Avatar
 
Join Date: Dec 2002
Location: Helsinki
maybe here

http://www.huskyintl.com/parts/2.htm
  Reply With Quote
Old 2nd August 2007, 06:18 AM   #4
diyAudio Member
 
WALTER BURKHARD's Avatar
 
Join Date: Dec 2002
Location: Helsinki
For 2SC1494 u can used NTE320
  Reply With Quote
Old 2nd August 2007, 06:21 AM   #5
diyAudio Member
 
WALTER BURKHARD's Avatar
 
Join Date: Dec 2002
Location: Helsinki
Or BLW60 -VHF Power Transistor from Philips Semiconductors
  Reply With Quote
Old 2nd August 2007, 11:07 AM   #6
ilimzn is offline ilimzn  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: Zagreb
I'm not sure but i think i remember one of the restorers of vintage gear at www.audiokarma.org having some experience with these. maybe you should ask there?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trio (Kenwood) DP-1000, Any info? GJF Digital Source 63 9th October 2013 09:48 AM
Trio/Kenwood CS1575A help lumanauw Everything Else 0 1st November 2006 06:48 AM
Trio (kenwood) LS-77 PTSOUNDLAB Multi-Way 5 7th April 2006 09:04 PM
kenwood trio el84 push pull schematic then_dude Tubes / Valves 0 12th October 2004 07:37 PM
FS: Kenwood (TRIO) L-05M and L-07MII MJR Swap Meet 1 8th September 2003 01:16 AM


New To Site? Need Help?

All times are GMT. The time now is 09:31 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2