arcam alpha 7 amp - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st July 2007, 03:02 PM   #1
stand is offline stand  England
diyAudio Member
 
Join Date: Jul 2007
Default arcam alpha 7 amp

the fuse keeps blowing ,what seems to be the problem needs help ...thanks
  Reply With Quote
Old 31st July 2007, 03:05 PM   #2
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Hi,
the problem is no sound.
Try a six inch nail to replace the fuse and make a good job of it. Now you'll hear a sound!

Seems like you need the help of a technician to sort this out.
__________________
regards Andrew T.
  Reply With Quote
Old 31st July 2007, 09:43 PM   #3
stand is offline stand  England
diyAudio Member
 
Join Date: Jul 2007
thanks for your kindness ..i just want to know the honest answer for this...so if you dont know dont answer..
  Reply With Quote
Old 31st July 2007, 09:49 PM   #4
Netlist is offline Netlist  Belgium
diyAudio Moderator Emeritus
 
Netlist's Avatar
 
Join Date: Jan 2003
stand,

We need a bit more info is what Andrew meant.
What fuse is blowing, the mains- or, if any, the output fuse? How does the fuse look? Blackened, or is the wire just melted?
Some history would be nice too. Did you party with the amp? Was it lying there for years unused...
What have you already done and do you have some basic measuring instruments available?

/Hugo
  Reply With Quote
Old 1st August 2007, 12:38 AM   #5
jaycee is offline jaycee  United Kingdom
diyAudio Member
 
Join Date: Apr 2004
Location: Norwich, UK
At a guess, the output mosfets have blown on one channel. This seems to be a common thing to happen to these amps, especially if pushed too hard or abused. However that's not a definite solution as this amp has only the mains fuse protecting it, so a fault anywhere in the amp could cause the fuse to blow.

If you have some experience with electronics, then we can suggest a few things. If however, you don't, then I advise you send it back to Arcam for repair.
  Reply With Quote
Old 2nd August 2007, 09:16 AM   #6
stand is offline stand  England
diyAudio Member
 
Join Date: Jul 2007
sorry about that....i just had this amp for about a week and using it for about 10 minutes when it happens ...i used to build my own gear just amp and pre amp (tubes) with diagram,i also do some minor troubleshooting.,,,in my country (philippines).you can easily get spare parts i dont know here in england.
  Reply With Quote
Old 2nd August 2007, 09:24 AM   #7
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
Drop an email to Arcam customer support. They are very friendly and helpful, and will send you the schematic for free and/or give you a quote for a factory repair.
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 3rd August 2007, 02:57 PM   #8
stand is offline stand  England
diyAudio Member
 
Join Date: Jul 2007
Default arcam alpha 7 amp

does anyone knows where to get this IRF 540 FETs ,and do i need to replace all of it? ....
  Reply With Quote
Old 3rd August 2007, 03:51 PM   #9
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Hi,
does the Arcam Alpha have an Nchannel quasi complementary output stage using irf540 vertical FETs?

If the answer is yes, then these are the cheapest and easiest to obtain FETs around.
And a second YES, replace all those in the dead channel.
__________________
regards Andrew T.
  Reply With Quote
Old 4th August 2007, 06:36 PM   #10
big jim is offline big jim  England
diyAudio Member
 
Join Date: Feb 2006
Location: london
Hi you can get the fets from maplins

i have many times

good luck. jim
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
arcam alpha 7 big jim Solid State 3 19th June 2006 12:40 PM
Arcam alpha 9 pumpkin Solid State 0 5th October 2005 07:31 PM
Arcam Alpha 7SE trwh Swap Meet 0 14th July 2004 11:27 AM
Arcam Alpha 8 ManUtd Digital Source 4 5th April 2004 03:23 PM
Arcam Alpha 5 + j baldam Digital Source 1 9th July 2003 11:20 PM


New To Site? Need Help?

All times are GMT. The time now is 01:25 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2