Harman Kardon 6550 amp fault finding - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th July 2007, 05:01 PM   #1
diyAudio Member
 
Join Date: Jun 2006
Location: West Oxon
Default Harman Kardon 6550 amp fault finding

Solely on the basis that I know which end of the soldering iron to hold, I agreed to look at a mate's faulty HK6550 amp.

He had experienced it losing volume over a short period, fading to nothing in about a minute. On restart - nothing.

When it got to me, apart from surprisingly shoddy build, eyeballing it revealed nothing - no blown caps or burned boards, startup produced no tortured screams or puffs of smoke (more's the pity...)

SFAICT voltages were fine up to the output stage, but there was nothing at the loudspeaker terminals.

To make myself feel useful I cleaned all earth connections, sockets, switches and pots.

Now I have *some* voltage at output, it plays music and nothing shows obvious signs of strain or excessive temperatures, but if I go over about 20% on the volume pot there is no rise in volume but a HUGE rise in distortion...

It's going to be a PITA to strip down, so can anyone suggest where I should look first for this problem?

thanks, eofs
  Reply With Quote
Old 11th July 2007, 05:42 PM   #2
Netlist is offline Netlist  Belgium
diyAudio Moderator Emeritus
 
Netlist's Avatar
 
Join Date: Jan 2003
Do you have a schematic? Does it have an output relay?

/Hugo
  Reply With Quote
Old 11th July 2007, 05:47 PM   #3
diyAudio Member
 
Join Date: Jun 2006
Location: West Oxon
I don't have a schematic - not managed to find one on the net, but will be contacting HK.

I believe it does have output relays.
  Reply With Quote
Old 11th July 2007, 05:51 PM   #4
Netlist is offline Netlist  Belgium
diyAudio Moderator Emeritus
 
Netlist's Avatar
 
Join Date: Jan 2003
Alright, i bookmarked this thread. Perhaps others here have a (similar) schematic.

/Hugo
  Reply With Quote
Old 11th July 2007, 06:04 PM   #5
diyAudio Member
 
Join Date: Jun 2006
Location: West Oxon
Thanks
  Reply With Quote
Old 12th July 2007, 02:17 PM   #6
diyAudio Member
 
Join Date: Jun 2006
Location: West Oxon
Not had much time to devote to this, but besides the other issues described, I notice the amp is completely out of phase (polarities reversed at output).

Any thoughts? Anyone? Click the image to open in full size.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Harman Kardon AVR 10 halloweenguy Everything Else 6 1st February 2010 05:52 PM
For Sale Harman Kardon T60 Turntable / Harman Kardon Cd491 Cassette Deck electric blue Swap Meet 1 25th August 2006 11:36 PM
Harman-Kardon PM 665 sangram Solid State 1 17th May 2006 06:32 AM
Harman Kardon amp Ilianh Solid State 10 26th December 2005 03:27 PM
Harman Kardon amp RancidAltoid Solid State 0 10th February 2005 12:28 AM


New To Site? Need Help?

All times are GMT. The time now is 06:37 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2