Need help with a B&K AVR202 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th July 2007, 08:23 PM   #1
jcorkin is offline jcorkin  United States
diyAudio Member
 
Join Date: Jan 2007
Location: saint marys georgia
Default Need help with a B&K AVR202

so my center channel wasnt working, so i opened up the amp and found that it had a blown fuse on the center channel replaced the burnt fuse with a 250v 4amp slow blow like what is in there and then the two transistors for that half of that channel fried, the part # for the transistors is J162 then 6L3, i cant seem to find them anywhere, also does anybody have the schematics for this amp? also what else should i replace along with those transistors? any help is appreciated.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 01:24 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2