Krell KSA-150 will not turn on - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th May 2007, 09:42 PM   #1
Doral is offline Doral  United States
diyAudio Member
 
Join Date: May 2007
Hello. I am looking for a schematic for a KSA-150. ANATECH : I see you have a schematic of the control board, but I cannot make out the components. Mine will not come on because it simply fries the 4 - 10ohm resistors immediately. Someone else has had their hands in this one, so I am not even sure the 110/220 switches are in the correct position. I tried to start a new post, but it will not let me since this has some of the same info.
  Reply With Quote
Old 31st May 2007, 03:00 AM   #2
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Default Your new thread

Hi Doral,
Okay, I split this off for you. There was a small box on the upper right asking you to check it if you have already searched.

First, check your mains settings. I'm going to bet that you have a short somewhere in the power supply or amp sections. This would cause the surge relays to remain off and allow the resistors to burn. This is from memory because I can't find a diagram of the primary circuit at this moment.

-Chris
__________________
"Just because you can, doesn't mean you should" my Wife
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Krell KSA-300S will not turn on fcel Solid State 52 18th February 2013 08:33 PM
Full-turn/partial-turn pots slowpogo Parts 1 12th January 2007 07:40 AM
How can I reduce mechanical turn on and turn off noise? soundNERD Chip Amps 8 28th October 2003 01:43 AM


New To Site? Need Help?

All times are GMT. The time now is 09:13 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2