Cyrus Pre, faulty or normal? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th April 2007, 07:32 AM   #1
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Question Cyrus Pre, faulty or normal?

Hi,
my Cyrus pre-amp with PSXr is sending out 100Vdc to 115Vdc on the audio ground line (RCA barrel) when disconnected from the receiver.

If I link a 10r to earth the voltage drops to around 0.1mV.

Is this normal?

I discovered it while investigating the earthing of my Leach. That same 110Vdc was passing through the active crossover and appearing on the Leach audio ground if the disconnecting network was temporarily broken. It sparks (very slightly) if connected while live.
__________________
regards Andrew T.
  Reply With Quote
Old 15th April 2007, 07:54 AM   #2
diyAudio Member
 
Jan Dupont's Avatar
 
Join Date: Apr 2003
Location: Copenhagen, Denmark
Send a message via MSN to Jan Dupont
Hi Andrew
You measured 107 VDC with reference to what ? Signal ground ?
__________________
Free Schematic and Service Manual downloads www.audio-circuit.dk, Company: www.dupont-audio.com, Joint venture: www.DupontMantra.com
  Reply With Quote
Old 15th April 2007, 08:58 AM   #3
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Hi Acd,
110Vdc above reference to earth pin on the socket/plug/chassis.
__________________
regards Andrew T.
  Reply With Quote
Old 15th April 2007, 09:19 AM   #4
diyAudio Member
 
Jan Dupont's Avatar
 
Join Date: Apr 2003
Location: Copenhagen, Denmark
Send a message via MSN to Jan Dupont
I cann´t recall ......
Do you use Mains earth connection over there ?
__________________
Free Schematic and Service Manual downloads www.audio-circuit.dk, Company: www.dupont-audio.com, Joint venture: www.DupontMantra.com
  Reply With Quote
Old 15th April 2007, 09:29 AM   #5
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Hi,
mains safety earth for all except double insulated.

The Cyrus is not double insulated, so the ground voltage is surprising. Gives the impression they really do have a floating audio ground in the pre-amp, or something gone open circuit?
__________________
regards Andrew T.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
normal X-Amp uli Pass Labs 42 19th November 2010 06:31 AM
denom pma250 amp faulty,but no faulty parts found please help homertooties Solid State 1 7th December 2008 03:58 PM
WTB Cyrus 1 or Cyrus 2 amplifier monstertrucker Swap Meet 0 20th November 2008 01:04 AM
Is it normal to think this way? gain wire Instruments and Amps 3 16th October 2008 11:09 PM
Cyrus Two - Faulty Speaker Channel Hedley Solid State 0 30th January 2008 10:57 PM


New To Site? Need Help?

All times are GMT. The time now is 10:16 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2