diyAudio (
-   Software Tools (
-   -   loading library file in protel 99 (

frdelijani 10th February 2005 06:50 AM

loading library file in protel 99
I just installed protel 99se. after creating a sch file, I go to tools, find, looking for component I need, but the program doesnt find it.
I know that 2n3904 is in BJT.LIB in sim.ddb and this ddb file exists in the path which is put in path edit box of "find schematic component" window. to the best of my knowledge, setting of this window is correct but it cant find the component.
when i go t browse sch to add a new library ddb like sim.ddb to the list, i get an error saying" file is not recognized"

thank you for your help

adx 11th February 2005 11:43 AM

try *2n3904* or just *3904* which will pick up all the weird variations

Reactance 8th April 2010 07:02 AM

Has anyone managed to resolve the issue when loading protel libs I too get the same error using windows 7,error " file is not recognized" let me know please. Thanks

adx 8th April 2010 09:22 AM

No problems with Protel in Win 7 so far. But I'm downgrading it to XP :)

That came up with a "format '% X' invalid" error. I found the solution on some Chinese site (Google translate does an excellent job), and that is to remove (or rename) any libraries that it might be trying to load (as part of a project for example), then load them back in. Might be related.

Reactance 8th April 2010 10:05 AM

This problem has something to do with windows 7 strict permissions when a file is being read, ive monitored the file load when the protel client.exe starts up, it reads outside the executing directory, ie: windows/system 32/*.cfg ect.. this might be the issue in terms of security.(Also i am not an administator on the windows 7 os but i do have rights to execute and install apps) there might be an issue where protel is trying to access configuration settings in the windows folder when attempting to "add libs or footprints"

Ive tested the same install on a windows-xp system it works 100% no issues, you might have no issue on windows 7 cause you are an administator on your os like me on xp pro.

renaming lib files wont do the trick im almost certain about that.

Let me know if anyone had / has similar issues. i would like to solve it when i get home today :)

and yes i do have the latest protel se sp6 installed.

adx 9th April 2010 12:42 AM

Yes, I am administrator, I can't remember if it asked for admin priveledges when installing, I don't think so.

I installed it with UAC enabled, which redirects all the silly files Protel puts in the windows directory to the virtual store. A nice idea, but Windows' implementation is a little flawed - if you then execute the app "as administrator" to solve some compatibility issue, then it forgets about the files in the virtual store and recreates them in \windows or wherever. That can make a mess of your config.

Interested so trying it now on my new (but useless) 8 core machine - I'm an administrator, but UAC enabled. Damn, same error you get when loading libraries, can't go any further. (Another reason to downgrade Win 7 to XP.)

Now run Protel as administrator. Of course it loses all my settings (or rather recreates them from scratch as above). Won't load anything. Make a new DDB - locks up and can't go any further.

That's an eye opener - had I known that I would have made the decision to downgrade Win 7 much earlier and saved myself a lot of time! Protel was one of the first apps I checked as it's a "must work" for my job, I obviously didn't go deep enough. Roll on that XP downgrade.

Sorry I can't help, other than to say the lastest version of VMware Player worked quite well with Protel in Windows 2000 / etc except for a small annoying mouse click delay. Screen redraw faster than native I think (another Win 7 problem?). Virtualbox has nasty redraw delays making it unusable for anything with polygons (fast until it reaches a certain track limit then it freezes repeatedly during redraws). Virtual PC aka "XP Mode" works (all this from fairly quick tests obviously) but is vastly slower than native so might as well stick with a 5 year old PC if you want to use Protel 99SE.

I'd be interested to know if you get this one solved, becasue we're all going to have to move to Win 7 or some derivative some time and need be able able to access our old files from old versions of CAD SW (to the *nix fanboys: no, Protel/Altium is not supported on Linux/Mac etc so that's not a choice we can make).

Reactance 9th April 2010 11:34 AM

Unable to work my pc was subjected to some sort of malicious software and i had to perform a restore on windows 7.

What happends if you disable UAC?

Im really egar to get protel to work tight and right, do you have the chineese link with the windows 7 fix ?

adx 9th April 2010 11:56 AM


Originally Posted by Reactance (
What happends if you disable UAC?

I assume the same as running as administrator (ie a crash). Trying it now... I stand corrected - same behaviour as with UAC on and not running as admin = works but fails to load libraries with the error message you mentioned.


Originally Posted by Reactance (
Im really egar to get protel to work tight and right, do you have the chineese link with the windows 7 fix ?

No, that was a Windows XP fix (needed after doing a Windows 2000 to XP upgrade).

BTW I've been using 64 bit Windows 7 for this.

Dave 2nd February 2011 02:18 AM

Anyone able to solve this problem with protel on Win 7?

adx 2nd February 2011 03:32 AM

Nope. I went to XP and never looked back. If I had to use Win 7 I'd run Protel under Vmware (or check if vbox is any better these days) - runs faster than native anyway.

Actually out of interest, installing it under latest virtualbox now (the benefit of a fast machine!), single processor, Win2k, all graphics accelerators on. No, that's fast, not a problem, I think they fixed the problem I had with it locking up halfway through redraws. There is some mouse lag, but nothing like we were used to using machines of the day, and nothing like what I remember from my last attempt.

I had to actually buy a copy of XP to get the suitable legal media/key to do the downgrade, so never did of course, and can legally dual boot Win 7 - but it's still broken, I haven't got around to repairing it, and have no need for it yet (Win 7 has the best 64 bit support).

All times are GMT. The time now is 06:24 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright 1999-2017 diyAudio

Content Relevant URLs by vBSEO 3.3.2