Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Software Tools SPICE, PCB CAD, speaker design and measurement software, calculators

Strange Eagle Issue
Strange Eagle Issue
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th September 2017, 01:59 PM   #1
Tenson is offline Tenson  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: Kent
Default Strange Eagle Issue

Anybody else found this problem?

I opened Eagle 7 and selected open library. I right-clicked the library I wanted to edit and made a copy. All seems fine, I proceed to edit the copy of the library and hit save.

When I look in the lbr folder using windows file explorer the new copy of the library is not there!

However, it does continue to show when I brows the lbr folder using Eagle. I can edit, save and use the new library. I looked at the file permissions and it is not hidden nor read only etc..
  Reply With Quote
Old 12th September 2017, 02:16 PM   #2
vzaichenko is offline vzaichenko  Russian Federation
diyAudio Member
 
vzaichenko's Avatar
 
Join Date: Jan 2010
Location: Moscow, Russia
Strange Eagle Issue
Hi Tenson,

Are you sure Eagle has saved the copy in the same folder where the original library has been placed? It looks like that copy is stored somewhere else.

Cheers,
Valery
__________________
If you can't explain it simply, you don't understand it well enough (c) Albert Einstein
http://vzaudio.com/
  Reply With Quote
Old 12th September 2017, 03:08 PM   #3
JMFahey is offline JMFahey  Argentina
diyAudio Member
 
JMFahey's Avatar
 
Join Date: Mar 2009
Location: Buenos Aires - Argentina
THAT !!!!! It was saved "somewhere else" but Eagle knows where it is

Hey!!!! ... it must have "Eagle eyes"
__________________
Design/make/service musical stuff in Buenos Aires, Argentina, since 1969.
  Reply With Quote
Old 12th September 2017, 04:19 PM   #4
vzaichenko is offline vzaichenko  Russian Federation
diyAudio Member
 
vzaichenko's Avatar
 
Join Date: Jan 2010
Location: Moscow, Russia
Strange Eagle Issue
Easy
For example, Diptrace doesn't allow saving into default folder, so user-modified libraries normally appear one level up from there.
__________________
If you can't explain it simply, you don't understand it well enough (c) Albert Einstein
http://vzaudio.com/
  Reply With Quote
Old 14th September 2017, 05:14 AM   #5
Mark Whitney is online now Mark Whitney  Netherlands
diyAudio Member
 
Mark Whitney's Avatar
 
Join Date: Feb 2013
Location: Netherlands
I had a similar problem. Windows was writing to a virtual directory and did not change the files set in the options settings. I moved the Eagle user files to Documents to fix the problem.
Also, check if the attributes of the files are not read only.

Disabling Windows 7 Virtual Store | InterWorks, Inc.
__________________
Regards Mark.
  Reply With Quote
Old 15th September 2017, 02:18 PM   #6
Tenson is offline Tenson  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: Kent
Quote:
Originally Posted by Mark Whitney View Post
I had a similar problem. Windows was writing to a virtual directory and did not change the files set in the options settings. I moved the Eagle user files to Documents to fix the problem.
Also, check if the attributes of the files are not read only.

Disabling Windows 7 Virtual Store | InterWorks, Inc.
Thanks I think that will work. I found if I save on the desktop the file appears. If I save anywhere in the program files folder it doesn't show up in file explorer but Eagle still sees it.

Would it help to run Eagle as Admin?

EDIT: Yes run as Admin allows Eagle to save in the lbr directory and it shows up in file explorer.

Last edited by Tenson; 15th September 2017 at 02:25 PM.
  Reply With Quote
Old 15th September 2017, 02:19 PM   #7
Tenson is offline Tenson  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: Kent
For others in the future, this seems like what is going on: I saved some files into the Program Files directory, and now they’re gone! – The Old New Thing
  Reply With Quote

Reply


Strange Eagle IssueHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange volume issue Konzentr8 Class D 28 30th October 2016 12:41 AM
Strange grounding issue... maybe caraudiofan Car Audio 12 11th February 2015 07:30 PM
Strange motorboating issue costis_n Tubes / Valves 72 15th October 2014 12:23 PM
strange printer behaviour with eagle Dan Moos Software Tools 3 26th May 2013 08:12 PM
Very Strange Preamp Issue Davec113 Tubes / Valves 12 6th August 2012 02:33 PM


New To Site? Need Help?

All times are GMT. The time now is 04:20 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki