Standard, platform independent simulations for DIYAudio - Page 5 - diyAudio
Go Back   Home > Forums > Design & Build > Software Tools

Software Tools SPICE, PCB CAD, speaker design and measurement software, calculators

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th February 2014, 11:22 PM   #41
diyAudio Member
 
keantoken's Avatar
 
Join Date: Aug 2006
Location: Texas
Blog Entries: 2
At the very least, LTspice will download the file and use it in the simulation. After it downloads it, I don't know what it does with it. The documentation for the .lib/.inc/.ferret commands is not detailed. I'll have to do some tests and see.

You don't have to say or do something special, just send Mike an email and describe the problem. I've done it and he responded even though I was mistaken.

Unfortunately, it won't allow to see those models in the GUI. Perhaps if you made a schematic in the /lib/cmp directory with that line, and the web file was named standard.bjt, it would rewrite it and show the new version in the GUI, but this would be inconvenient because you'd have to store all your schematics in the cmp directory. Furthermore, I don't know if LTSpice would detect the changes right away or if it would require a restart.

In Linux I could perhaps make a symbolic link in the schematic directory to /lib/cmp/standard.bjt, so that LTSpice would unwittingly overwrite the standard.bjt. I don't know if this could be done on Windows or Mac though.
  Reply With Quote
Old 28th February 2014, 02:18 AM   #42
gannaji is offline gannaji  India
diyAudio Member
 
Join Date: Jan 2011
Location: Hyderabad
Quote:
Originally Posted by keantoken View Post
First, see if you can download the file in your browser using this:

http://startfetch.com/keantoken/ltspice/kean4.bjt

If not, then it is a problem with the server or with your network. If you can download the file, then it's a problem with LTSpice. If you go to Help->About, it will give you Mike's email address and you can send him a report.
It is getting downloaded as "kean4.hmt"

edit: It could be renamed as kean4.bjt and opening in word pad normally.
__________________
www.samritatrust.org

Last edited by gannaji; 28th February 2014 at 02:20 AM.
  Reply With Quote
Old 28th February 2014, 03:30 AM   #43
godfrey is offline godfrey  South Africa
diyAudio Member
 
Join Date: Nov 2009
Location: Cape Town
Quote:
Originally Posted by davidsrsb View Post
Maybe you should standardize on a "DA" suffix on the models (like Bob Cordell does with "C") to let LTSpice choose the correct library
That was a bit of a brain-fart, IMHO, since a lot of parts can have a suffix anyway e.g. there's BC547A/B/C as well as ungraded BC547. Apparently Bob based his models on ungraded parts, so the "C" suffix can be misleading.

Anyway, my solution was to edit the text file and add a "bob" prefix to all the part numbers. That also groups all the decent models together alphabetically, which I find useful.
  Reply With Quote
Old 28th February 2014, 04:56 AM   #44
diyAudio Member
 
keantoken's Avatar
 
Join Date: Aug 2006
Location: Texas
Blog Entries: 2
I use an underscore before the suffixes that aren't part of the part number, so I got that covered.

As I suggested earlier in this thread, if we work with LTspice instead of despite it, we can replace the standard.bjt with a read-only copy of a vetted model library, with model metadata added with inline comments rather than on the model number line. This could be more compatible with SPICE->PCB workflow and would just be a cleaner solution overall I think.
  Reply With Quote
Old 28th February 2014, 04:59 AM   #45
diyAudio Member
 
keantoken's Avatar
 
Join Date: Aug 2006
Location: Texas
Blog Entries: 2
Quote:
Originally Posted by gannaji View Post
It is getting downloaded as "kean4.hmt"

edit: It could be renamed as kean4.bjt and opening in word pad normally.
That's strange - could LTSpice be going through Explorer to do this, and Explorer is automatically renaming it? Try this:

Code:
.lib http://fidelityforce.com/keantoken/ltspice/kean4.bjt
And if that doesn't work, try this:

Code:
.ferret http://fidelityforce.com/keantoken/ltspice/kean4.bjt
.lib kean4.htm
I assumed you misspelled .htm to .hmt, but use the extension that it gets when downloaded.
  Reply With Quote
Old 28th February 2014, 08:53 AM   #46
diyAudio Member
 
keantoken's Avatar
 
Join Date: Aug 2006
Location: Texas
Blog Entries: 2
Try it again now. The webserver was changed so the file wouldn't try to display in the browser; that may what cause it to change the extension to .htm.
  Reply With Quote
Old 28th February 2014, 09:31 AM   #47
diyAudio Member
 
Join Date: Apr 2012
Location: Florida & France
Quote:
Originally Posted by keantoken View Post
I use an underscore before the suffixes that aren't part of the part number, so I got that covered.
Won't that prevent any integration with other packages? Such as eagle or whatever. When the part numbers are altered that way, they can't match.

Plus it's kind of disturbing to see on the schematics some odd looking part name, especially if those part names have been stretched with extraneous characters.

Quote:
Originally Posted by keantoken View Post
As I suggested earlier in this thread, if we work with LTspice instead of despite it, we can replace the standard.bjt with a read-only copy of a vetted model library, with model metadata added with inline comments rather than on the model number line. This could be more compatible with SPICE->PCB workflow and would just be a cleaner solution overall I think.
Exactly!! I think this is more suitable and work work better. It would be nice to see the exact part name on schematics too.
  Reply With Quote
Old 28th February 2014, 09:46 AM   #48
diyAudio Member
 
keantoken's Avatar
 
Join Date: Aug 2006
Location: Texas
Blog Entries: 2
The problem is, when I drop my library into a thread, no one will even try to use it unless it's an uncomplicated process.

I can't edit out the suffixes until I have a system in place that will make that a wise idea. Until then I have to make them stand out.
  Reply With Quote
Old 28th February 2014, 10:08 AM   #49
diyAudio Member
 
Join Date: Apr 2012
Location: Florida & France
Quote:
Originally Posted by keantoken View Post
The problem is, when I drop my library into a thread, no one will even try to use it unless it's an uncomplicated process.
You're likely right, it needs to be easy and simple.

Quote:
Originally Posted by keantoken View Post
I can't edit out the suffixes until I have a system in place that will make that a wise idea. Until then I have to make them stand out.
That's fine, we're searching and things will evolve. You've had plenty of very nice ideas so far to make this very good. Let's take it one step at a time.

I just tried again and got the same error. I'm posting a screenshot for illustration.
Attached Images
File Type: png Screen Shot 2014-02-28 at 11.04.33 AM.png (39.1 KB, 52 views)
  Reply With Quote
Old 28th February 2014, 10:13 AM   #50
diyAudio Member
 
keantoken's Avatar
 
Join Date: Aug 2006
Location: Texas
Blog Entries: 2
You'll have to ask Mike about it like I suggested. Does kean.bjt appear in the schematic directory?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Voltage independent power load egberttheone Power Supplies 15 23rd February 2012 06:44 PM
Parallel woofers - independent filter? Aleph 5 Multi-Way 18 16th August 2011 03:57 PM
Foam or rubber, environment independent? buggsson Car Audio 3 10th December 2008 01:06 AM
Independent (floating) supplies akis Power Supplies 15 7th September 2008 01:25 PM
Independent Bias Adjust for Each Tube? TubeHead Johnny Tubes / Valves 4 24th February 2008 01:57 PM


New To Site? Need Help?

All times are GMT. The time now is 12:12 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2