LTSpice and Amplifier Warm-up - diyAudio
Go Back   Home > Forums > Design & Build > Software Tools

Software Tools SPICE, PCB CAD, speaker design and measurement software, calculators

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 25th January 2014, 05:36 AM   #1
gankoji is offline gankoji  United States
diyAudio Member
Join Date: Dec 2013
Default LTSpice and Amplifier Warm-up

Hello everyone,

I've been looking for the answer to this question for some time now, haven't come up with anything good.

I'm currently simulating an amplifier before I breadboard the prototype. Using LTSpice to get an idea on component values to optimize bias and minimize distortion throughout the audio band. I also simulate the power supply, which is just a simple transformer/bridge rectifier/filter circuit.

Since the power supply takes a while to come up to full voltage due to the big capacitors, I use the delay function of the signal voltage source to apply the signal once the power supply stabilizes. This results in rather long simulation times, in comparison with 50 cycles at 20kHz.

For good distortion results, I keep the max timestep very small for high frequency analyses. But this results in excessive simulation times when you include the power supply stabilization times.

So here's the big question: is there a way to specify different max timesteps for different time ranges in the transient analysis? That way, I could use a rather long timestep for the first few seconds of the analysis, when no signal is applied, to simulate the power supply stabilization period, and a much smaller timestep when I apply the signal.

Anyone ever done that?
  Reply With Quote
Old 25th January 2014, 09:15 PM   #2
jcx is offline jcx  United States
diyAudio Member
Join Date: Feb 2003
Location: ..
spice doesn't do literal "warm up" - the device temperature is a static entry in the model

power on transients can be an issue too - probably what you mean

one possiblity is .loadbias/savebias files - you run a sim at a longer step time, for as long as needed to reach steady state
with the
.savebias ".\mybias" internal time=10s
file statement set to run at the end of the long sim and save the operating point at that time

then you add/enable the .loadbias ".\mybias" read of that saved operating point for the start of your high time resolution sim
  Reply With Quote
Old 25th January 2014, 10:08 PM   #3
gankoji is offline gankoji  United States
diyAudio Member
Join Date: Dec 2013
Jcx - that's is exactly what I meant. I suppose the warm-up title was a bit misleading. Anyhow, I will look up the load/savebias commands this evening and give them a shot. Thanks!
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
A very warm hello Dude111 Introductions 5 10th April 2013 11:42 AM
how to simulate an audio amplifier using ltspice davidel94 Solid State 5 6th March 2013 04:10 PM
how to simulate an audio amplifier using ltspice davidel94 Software Tools 14 24th October 2012 01:27 PM
What makes an amplifier "bright", "warm", or "neutral"? JohnS Solid State 51 13th December 2009 06:42 PM
Right channel volume softens when amplifier is warm starbucks_sg Solid State 1 22nd March 2006 08:51 PM

New To Site? Need Help?

All times are GMT. The time now is 06:15 PM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2