diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Software Tools (http://www.diyaudio.com/forums/software-tools/)
-   -   WinPCD version 1.0 released (http://www.diyaudio.com/forums/software-tools/230456-winpcd-version-1-0-released.html)

dlr 20th February 2013 05:56 PM

WinPCD version 1.0 released
 
It's been a long time getting to this point, almost a year, but the first version of the WinPCD, the .NET version of Jeff Bagby's PCD spreadsheet, is available for download. A few of you may have followed the progress posting at my web site, but for those who have not, you'll find some details there. I made the final changes late last night, so it's likely that a bug or two will still exist.

Please go first to my blog, I'm trying to work that in since it will allow users to post comments. This does require a request for a subscriber account, however. What I've read about spamming prevents me from making it a fully open blog, but please consider doing this so that partly as help to others who may consider using it.

I've updated my signature with a link to the blog (the link in my signature). From there you'll find a link to the download area.

I've already got a couple of additions in mind that are generic, but feel free to suggest changes. No guarantees on that, but all feedback will be carefully considered. There's still work to be done, but the core is done as are both the 2-Way and 3-Way sections. Some right-click context and mouse hover utility has been built-in, more to come over time (especially with usable feedback ).

Also, consider taking the poll found at my blog. I think I've got it set up so that anyone can take it, no account necessary.

Dave

Passinwind 20th February 2013 06:20 PM

First I've heard of this, and very much looking forward to using it. Thank you Dave, will give it a go presently.

dlr 4th March 2013 05:12 AM

Quote:

Originally Posted by Passinwind (Post 3378366)
First I've heard of this, and very much looking forward to using it. Thank you Dave, will give it a go presently.

Have you tried it out yet? I've got some changes made towards another release, but would like to get more feedback from users.

Dave

tvrgeek 4th March 2013 10:03 PM

Dave,PM me and I will provide the weekends feedback and samples of the xml and frs files.

I like this thing. Just need to help you wring the bugs out.
I have the better part of my quick start done for HOLM and SimpeS as those are the tools that will feed you the frs and zma files. I have an overall list of steps for all the tools needed, lists of where to get stuff, additional reading, and tips. It looks like about 20 pages.

tvrgeek 4th March 2013 10:18 PM

The frd input is due is the file size. When I deleted sub 10 Hz data, it shifted way over to where it went to zero. These stupid programs that calculate to ten decimal places when two is more than accurate! This file had "only" 1000 steps, but all three columns are 10 decimal places. If I were a coder, a perl script to clean it up would be really easy. I guess the best way is on ingest.

dlr 5th March 2013 12:05 AM

Quote:

Originally Posted by tvrgeek (Post 3395982)
The frd input is due is the file size. When I deleted sub 10 Hz data, it shifted way over to where it went to zero. These stupid programs that calculate to ten decimal places when two is more than accurate! This file had "only" 1000 steps, but all three columns are 10 decimal places. If I were a coder, a perl script to clean it up would be really easy. I guess the best way is on ingest.

I'd like to check out the files at issue. Would you send them to me? I'm not aware of that issue with my program. Mine ignores any data below 10Hz.

Dave

Passinwind 5th March 2013 01:15 AM

Quote:

Originally Posted by dlr (Post 3394866)
Have you tried it out yet? I've got some changes made towards another release, but would like to get more feedback from users.

I need to recover my FRD and ZMA files for my HF drivers off an older computer that I now use for audio measurements. I'll try to get to that tomorrow. I was able to load up the woofer data fine. It's been a good while since I used Jeff's version, but this one looks quite promising so far.

Passinwind 6th March 2013 06:31 PM

I will send an email so you can subscribe me to your blog. I got a lot of things working, but am unclear which other ones are enabled at this point.

tvrgeek 6th March 2013 10:54 PM

Quote:

Originally Posted by dlr (Post 3396101)
I'd like to check out the files at issue. Would you send them to me? I'm not aware of that issue with my program. Mine ignores any data below 10Hz.

Dave

We had a couple issues here.

First, HOLM was putting "#" as comments, so short term, delete the comments from a HOLM file. Dave identified this and will update the future version.

You can cut down the number of points it exports. 1000 is the default. 500 is just fine for this. Either works.

Second is that HOLM puts out files referenced to 0dB. Dave expects absolute values. Here is how I achieve that:

1: I have a reference driver that I know, or at lease assume the efficiency of mounted in a baffle. I set up the distance to the mice with my meter-stick exactlly, fiddle with all the levels until I get a nice happy plot in Holm. I use a short gate time and smooth 1/3 octave. I then record what the level is at 2Khz. Adding this to the reference SPL gives me the offset I need to add to the HOLM export of my drivers under test.

2: Measure all my drivers, not touching anything in the setup.

3: Import into EXCEL as text.

4: Insert a column and an equation to add the offset, 107.2 in this case, to all the amplitude values.

Move the original amplitude column out of the way. You can't get rid of it due to the equitation reference.

5: Copy the three columns into WordPad. It won;t complain about it being a table.

6: Save as TEXT. This gets rid of the table leaving yo with a nice three column tab delimited .frs file. These also import into PSD-Lite and plot with the "real" amplitudes.

Only takes a few seconds really. HOLM does have an offset, but it does not like to go more than a few dB. Maybe it exports OK, but it sure can't display.

ton64 13th March 2013 03:00 PM

DAVE,
Nice program with a well choosen layout.
I have down loaded the program and try it out. The box-tools does not working. Here with the advice to add box-tool1 and box-tool2 (e.g for woofer and a mid enclosure).
It give more services by easy overview and corrections. Inform me why the box scheduler not is activated.
At the present I am working with Jeff's Excel-Designer 7 (2003).

wmbr, ton


All times are GMT. The time now is 02:32 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2