diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Software Tools (http://www.diyaudio.com/forums/software-tools/)
-   -   Ltspice. What have I done to break it !! How do I put it right. (http://www.diyaudio.com/forums/software-tools/226949-ltspice-what-have-i-done-break-how-do-i-put-right.html)

Mooly 3rd January 2013 01:21 PM

Ltspice. What have I done to break it !! How do I put it right.
 
1 Attachment(s)
Today I inadvertently clicked file > new symbol instead of new schematic. I exited and carried on without giving it a second thought.

Now, when I right click a transistor and pick new transistor I am offered both NPN and PNP models. Same for FET's.

I then went and tried my old laptop which also has Ltspice and that was OK. It offers the correct choices of only NPN or PNP. So I tried the same on this one too and clicked file > new symbol and THE SAME THING has happened. That to now offers both NPN and PNP models.


What have I done :D

Mooly 3rd January 2013 02:48 PM

I'm now wondering if this is an issue with the latest library update. I seem to remember updating a week or so back and the program files change log shows December 27th as the date the file changed. I hadn't used the program since.

The older laptop I tried and it was OK but I also ran the library update (today). Too much of a coincidence.

Mooly 3rd January 2013 03:41 PM

1 Attachment(s)
Seems its a faulty update.

Proved by using Acronis to roll back to the 26th before I did the update.

Osvaldo de Banfield 3rd January 2013 03:48 PM

Perhaps in the new update there are NPN and PNP FET's! :-))

Ray Waters 3rd January 2013 04:38 PM

I see the same behavior in the current version (4.17q) so I agree with Mooly -- it's a bug, but I'm not sure which version it first showed up in.

It's probably best to report bugs in the Yahoo LTspice group; I haven't had a lot of success reporting bugs to the program's author directly.

Ray

Mooly 3rd January 2013 05:46 PM

Thanks for also confirming the issue Ray. I'm not a member of the user group... I probably should be. The link to report bugs (from within LTspice) wouldn't do anything although the other two links did. So that seems a bit of a deliberate move.

Ray Waters 3rd January 2013 06:05 PM

There is a bug report link in the LTspice Help | About dialog box, as you said, and on my system it will open my email client to send a direct email to Mike Engelhardt, the program's author. From what I can tell, Mike is the sole maintainer of LTspice so I'm sure he is a busy guy and gets tons of bug reports this way. I can't blame him for not paying much attention to mail from people he doesn't have any experience with, but one user with credibility is Helmut over in the Yahoo group. Helmut is very active in the group and if he sees a bug report and can reproduce it he'll make the bug report to Mike himself. This usually gets quick results.

I don't frequent the Yahoo group often but it is a good source for libraries and tutorials. If I get a minute or two, I'll check in and see if anyone else has posted on this issue. If not, I'll mention it myself.

Ray

Mooly 3rd January 2013 06:09 PM

Thanks for that Ray, that would be great. I solely use web based mail so haven't an email client as such configured, probably the reason the link appears to do nothing for me.

Cheers...

Ray Waters 3rd January 2013 09:29 PM

This did come up in the Yahoo forum today, where Helmut agreed this is a bug and recommended it be reported to Mike as such. I won't add to Mike's email clutter so I'll not make a report myself (for now). It will probably be fixed in the next day or so (although the bug is still present as of version 4.17r).

Ray

Ray Waters 4th January 2013 04:05 AM

UPDATE:

This has been fixed in version 4.17s.

Ray


All times are GMT. The time now is 11:31 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2