Transmission Line Modelling Software - Page 41 - diyAudio
Go Back   Home > Forums > Design & Build > Software Tools

Software Tools SPICE, PCB CAD, speaker design and measurement software, calculators

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd January 2013, 07:11 PM   #401
wmb is offline wmb  United States
diyAudio Member
 
Join Date: Nov 2004
Location: Hawaii
Nice update.

Over the holiday, I installed a Dayton IB385-8 Infinite Baffle Subwoofer in my living room. I was initially planning to put it in the fireplace, using the chimney as the back port, but modeling with TL suggested that was not a good idea. So I installed it in a trap door that goes outside to a covered firewood cabinet. It's working great in that configuration, and the Wife Acceptance Factor is much better than the fireplace-mount :-)
  Reply With Quote
Old 11th January 2013, 08:34 PM   #402
wmb is offline wmb  United States
diyAudio Member
 
Join Date: Nov 2004
Location: Hawaii
Default Unhandled exception

I just got an unhandled exception while clicking in the SPL window with the intention of showing some cursor lines. Usually if I click Continue the dialog will go away and I can proceed, but this time the exception just kept coming back.

The details were:

System.OverflowException: Arithmetic operation resulted in an overflow
at TransmissionLine.myGraphClass.DrawCursorLine(Point MousePosition, PictureBox& DisplayBox)
at TransmissionLine.Form1.GraphCursorLines(Point Mouse, PictureBox& myDisplay, myGraphClass& Graph)
at TransmissionLine.Form1.GraphMouseMove(Object sender, MouseEventArgs e)
at System.Windows.Forms.Control.OnMouseMove(MouseEven tArgs e)
at System.Windows.Forms.Control.WmMouseMove(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.O nMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.W ndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


In the status bar at the bottom of the window, it says:

Freq: 0 Hz Value: [Infinite Baffle = 0] [Driver = 0] [Terminus = 0] [System = 0]

The only way to get the exception to stop was to move the exception dialog box out of the SPL window before dismissing it - and then it would reappear as soon as I moved the mouse cursor back into the SPL window, even without any mouse clicks.

I wonder if DrawCursorLine could be dividing by 0?
  Reply With Quote
Old 11th January 2013, 08:40 PM   #403
wmb is offline wmb  United States
diyAudio Member
 
Join Date: Nov 2004
Location: Hawaii
Aha, here's the clue that should make solving the problem easy!

The exception only happens if the SPL window "Terminus" check box is checked and the enclosure has no open-ended elements. If I uncheck Terminus, the problem goes away and the line cursors appear normally, or if I open-end an element and check Terminus, all is well.
  Reply With Quote
Old 13th January 2013, 06:26 AM   #404
diyAudio Member
 
Join Date: Feb 2010
Location: in half space
Quote:
Originally Posted by wmb View Post
I just got an unhandled exception while clicking in the SPL window with the intention of showing some cursor lines. Usually if I click Continue the dialog will go away and I can proceed, but this time the exception just kept coming back.
I had the same thing happen.


I've also had trouble zooming in close on a figure to get the the sides of the elements aligned. If you get too close, the display goes white, and you can't get the figure back no matter how much you zoom. Closing the program doesn't help, I had to restart the computer. Even then it opened with a white window for the default. I was able to zoom out and find the figure, however.

I think some sort of button that restored the display would be a good feature.
  Reply With Quote
Old 13th January 2013, 06:58 AM   #405
diyAudio Member
 
Join Date: May 2009
Location: Wellington
Quote:
Originally Posted by wmb View Post
... So I installed it in a trap door that goes outside to a covered firewood cabinet. ...
Something like this?

Infinite Baffle Subwoofer
  Reply With Quote
Old 13th January 2013, 04:34 PM   #406
wmb is offline wmb  United States
diyAudio Member
 
Join Date: Nov 2004
Location: Hawaii
Wow. When you aren't listening to it, you could use that setup to kill small animals, or at least drive them from the house in abject terror :-)

My IB sub is nothing special, just a single 15" Dayton IB 385-8. The only thing interesting about it is that I clamped the magnet between two-by-fours and screwed that to the frame of the house so the baffle vibrates less.

It's loud enough and then some with a 200W amp. The room entry point is very near a corner. The only room mode that it seems to excite is the primary resonance of the 35' length of the long narrow room, so there is a 30 Hz peak to deal with. So far I haven't bothered to eq-out the peak, as it is too low to affect the balance of most music. For movies, it's sort of fun having the extra zip to the LF effects.
  Reply With Quote
Old 15th January 2013, 01:43 PM   #407
diyAudio Member
 
Join Date: Feb 2010
Location: in half space
Now I can't find the figure at all, even with reboots. Do you think if I removed the program and re-installed it, I'd get it back?

Trouble is, without the figure there's no longer any way to select elements, so the program has become useless.
  Reply With Quote
Old 15th January 2013, 04:25 PM   #408
uptime is offline uptime  United States
diyAudio Member
 
Join Date: Mar 2012
Quote:
Originally Posted by Don Hills View Post
Something like this?

Infinite Baffle Subwoofer
Wow. I hope you don't have neighbors (and have updated your earthquake insurance)?
  Reply With Quote
Old 15th January 2013, 04:44 PM   #409
diyAudio Member
 
Mosquito's Avatar
 
Join Date: Sep 2009
Location: Santa Fe, Argentina
Hi, that's strange, I have the program running normally, I can maximize and minimize the figure w/o any problem...
Every saved project re-opens normally as well...
__________________
If I only had a dollar for every song I've sung...
  Reply With Quote
Old 15th January 2013, 04:58 PM   #410
diyAudio Member
 
Mark.Clappers's Avatar
 
Join Date: Jan 2010
Location: The Netherlands, near the German border
Hi,

I get an error to when minimising and maximising, but can continue without problems. Running win7 64bit.
Attached Images
File Type: jpg error.jpg (67.3 KB, 167 views)
__________________
Music is art - Audio is psychoacoustics & engineering

Last edited by Mark.Clappers; 15th January 2013 at 05:01 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TLwrx v 3.0 Transmission Line Software CarlosT Subwoofers 16 27th March 2008 04:25 PM
3 Way Crossover modelling Software? Grahame Multi-Way 3 13th May 2007 04:50 AM
Matlab-based triode modelling software Radames Tubes / Valves 1 16th September 2005 07:36 PM
3d modelling software greg_mcquaid Multi-Way 17 22nd May 2004 07:03 AM


New To Site? Need Help?

All times are GMT. The time now is 01:23 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2