Does Praxis and Windows 7 work - diyAudio
Go Back   Home > Forums > Design & Build > Software Tools

Software Tools SPICE, PCB CAD, speaker design and measurement software, calculators

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th May 2012, 06:37 AM   #1
pjwd is offline pjwd  Australia
diyAudio Member
 
Join Date: Nov 2004
Location: Brisbane
Default Does Praxis and Windows 7 work

Has anyone used praxis with windows 7 ( just to view files - not measure) - seems to me it works when first opened and subsequently it does not work and in fact freezes open and does not respond . I would love to know if there is a fix or I am doing something stupid

Regards,

Phil
  Reply With Quote
Old 5th June 2012, 05:42 PM   #2
diyAudio Member
 
Join Date: Jan 2009
I have the Praxis demo working in Win7 without freezing or crashing (no audpod). My computer is not doing anything special to my knowledge. The sound card I am using is a Lynx L22.

I was just about to email the company to find out the limitations of the demo program. The frequencies I am able to look at seem limited. If I alter the initial RTA graph in any way, the graph changes and I am limited to frequencies above 800 some Hz.

Aside from that, I am liking the 1/48 octave resolution.
  Reply With Quote
Old 5th June 2012, 11:09 PM   #3
pjwd is offline pjwd  Australia
diyAudio Member
 
Join Date: Nov 2004
Location: Brisbane
Hyper etc. - thanks for the response - I have the audpod which I use for measurement on an XP machine and it is fine - I often have used the demo mode on work computers to look at and process impedance and frequency plots, transfer them into lspcad etc. and there has never been any limitation ( up until win7) - I wonder if your problem is a milder version of the issue I have ( I have tried it on 3 machines all with the same results and running in "XP" mode does not alter it ) - my recollection is that I can use it to full functionality when I first open Praxis on a win 7 machine but when I open it the second time it does not work

Very curious - I have asked some IT boffins so if I learn anything I will let you know

Cheers,

P
  Reply With Quote
Old 6th June 2012, 05:03 PM   #4
diyAudio Member
 
Join Date: Jan 2009
Update: So I found the solution to my issue. The FFT size was set too low. This limited the frequencies I was able to view.

I loaded up a .wav file and the program did not crash. I changed things around trying to get the program to crash, but have no clue what I'm doing ^_^

Praxis was set with the stock settings it installed with thereby not duplicating the conditions of the problem you are experiencing. Also, I did not save the settings from having the .wav file loaded to see if loading it a 2nd time would crash the program.

It would be a pain, but you might try a different install of Win7 or perhaps a fresh install on your computer?
  Reply With Quote
Old 7th June 2012, 01:30 AM   #5
pjwd is offline pjwd  Australia
diyAudio Member
 
Join Date: Nov 2004
Location: Brisbane
good news - still lost in the cyber fog here - the fact that it happening on 3 separate computers and is Ok on yours is a puzzle - thanks for the feedback

P
  Reply With Quote
Old 2nd July 2012, 04:53 AM   #6
clem_o is offline clem_o  Philippines
diyAudio Member
 
Join Date: Jun 2005
Location: Manila
Default It seems to...

Praxis and Win7 - yes, with and without the audpod. Most recently was used to measure a room's RT60 - the computer had an Asus Xonar Essence. I remember there were a couple of "issues" but mostly with the settings of the sound card.

There are several flavors of Win7: we had it running on the 32-bit version I think...

Cheers
  Reply With Quote
Old 8th July 2012, 06:43 AM   #7
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
Getting Praxis working on Win 7 is a challenge and liable to drive you nuts. Don't even try on 64 bit. The Win 7 sound engine works so differently that its difficult to keep the samples clean through it. Even making everything run at the same sample rate is not obvious.

Opening files on the 64 bit version doesn't work well enough to bother.

If you use Praxis seriously then set up an XP system for it. A virtual machine won't work because it virtualizes the sound card as a soundblaster.

I have made it work with everything set and locked to 48 KHz 16 bit but it still was unstable. I only use it that way under duress (remote measurements from a laptop).
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 8th July 2012, 11:35 PM   #8
pjwd is offline pjwd  Australia
diyAudio Member
 
Join Date: Nov 2004
Location: Brisbane
Thanks I audio - I am only wanting to view and play with files on win7 - I have an xp laptop for measurements which works fine - weirdly it works the first time on a pc and then will not open completely after that - could be that problem is that they are the 64 bit machines

cheers,

Phil
  Reply With Quote
Old 9th July 2012, 01:16 AM   #9
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
I can't get Praxis to even open correctly on my Win 7 64 system. It locks up almost instantly. Its seems that something about accessing the hardware is locking it up. Probably not fixable. I'm reinstalling XP mode and I'll see what happens.
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 9th July 2012, 01:47 AM   #10
pjwd is offline pjwd  Australia
diyAudio Member
 
Join Date: Nov 2004
Location: Brisbane
Demian - I could not get it to work on XP3 mode - in fact that does seem to work with any legacy software. Bill Waslo said he has it working in win7 but I am not sure if it was 64 bit

Phil
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opinions on Praxis Loren42 Software Tools 1 18th August 2011 03:49 PM
Praxis vs Sample Champion Erik F Multi-Way 4 11th November 2008 09:42 PM
Help with praxis dumrum Multi-Way 0 29th June 2004 07:09 PM
ClioWin and Praxis niner Multi-Way 1 20th October 2002 06:05 PM


New To Site? Need Help?

All times are GMT. The time now is 01:41 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2