HOLMImpulse: Measuring Frequency- & Impulse-Response - Page 41 - diyAudio
Go Back   Home > Forums > Design & Build > Software Tools

Software Tools SPICE, PCB CAD, speaker design and measurement software, calculators

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st September 2009, 11:07 PM   #401
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: Kona, Hawaii
Blog Entries: 4
Interesting stuff. What do you think your MP3 comparison is showing?
Big trouble below 30Hz in amplitude and phase is what I see.
  Reply With Quote
Old 2nd September 2009, 10:28 PM   #402
diyAudio Member
 
Join Date: Mar 2003
Location: Denmark, Copenhagen
Question Moving this thread

I would like to move this thread to Software Tools:
http://www.diyaudio.com/forums/software-tools/

Some days ago I have sent a message from:
http://www.diyaudio.com/forums/sendmessage.php
But I have not got a reply yet - they might be busy upgrading.

According to:
http://www.diyaudio.com/forums/faq.p...b3_mods_admins
Moderators can move threads - but how do I contact a moderator?
__________________
Follow your first Impulse with HOLMImpulse
  Reply With Quote
Old 2nd September 2009, 11:38 PM   #403
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: Kona, Hawaii
Blog Entries: 4
a mod should see this soon and move it.

I don't see the "report this thread" button that the old forum had.
  Reply With Quote
Old 10th September 2009, 02:35 PM   #404
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: Kona, Hawaii
Blog Entries: 4
Bug or feature?
In the recent versions of HOLM it seems difficult to get a good plot if the sweep starts above ~20Hz. The bottom end of the plot never looks right.

For example if the sweep is started at 250Hz for a midrange horn, the graph under 250 never looks right, either in gated or total response mode. Even with a high pass applied after the measurement. The graph is flat or even rising toward the low end.

In earlier versions this seemed to be no problem. Is there a new setting to make this work? Or is there a change?
  Reply With Quote
Old 10th September 2009, 03:50 PM   #405
diyAudio Member
 
Join Date: Mar 2003
Location: Denmark, Copenhagen
Default It's a new bug

Quote:
Originally Posted by panomaniac View Post
Bug or feature?
In the recent versions of HOLM it seems difficult to get a good plot if the sweep starts above ~20Hz. The bottom end of the plot never looks right.
In earlier versions this seemed to be no problem. Is there a new setting to make this work? Or is there a change?
It's a new bug - thanks for reporting

(The signal most be highpassed, but the feature as attached is not working)
Attached Images
File Type: png ScreenShot001.png (1.4 KB, 362 views)
__________________
Follow your first Impulse with HOLMImpulse
  Reply With Quote
Old 10th September 2009, 05:33 PM   #406
Elias is offline Elias  Finland
diyAudio Member
 
Elias's Avatar
 
Join Date: May 2003
Location: Where you live
Hello Ask Bojesen,

This was some time ago, but did you come up with a solution with this windowing issue?

Quote:
Originally Posted by askbojesen View Post
But is that a FFPO ? I lack a definition of FFPO.

Note: I did not try your software I'm more generally interested about this as I'm thinking how to improve my own code I've done with GNU OCTAVE.

- Elias
__________________
Liberate yourself from the illusion of two speaker stereo triangle
Dipole Bass vs Monopole Bass Stereophonic Sound from a Single Loudspeaker 3 Speaker Linear Stereo Matrix Wavelets
  Reply With Quote
Old 11th September 2009, 03:35 PM   #407
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: Kona, Hawaii
Blog Entries: 4
Thanks Ask. Looking forward to the fix. It's an important feature.
  Reply With Quote
Old 11th September 2009, 05:06 PM   #408
diyAudio Member
 
Join Date: Mar 2003
Location: Denmark, Copenhagen
Default Highpass

Quote:
Originally Posted by panomaniac View Post
Thanks Ask. Looking forward to the fix. It's an important feature.
Well until I fix the auto post highpass you can highpass the measurement from the options window (See attachment)
Attached Images
File Type: png ScreenShot002.png (2.1 KB, 316 views)
__________________
Follow your first Impulse with HOLMImpulse
  Reply With Quote
Old 17th September 2009, 03:22 PM   #409
breez is offline breez  Finland
diyAudio Member
 
Join Date: Jul 2004
Location: Finland
Hi askbojensen and thanks for the software! I'm probably moving from ARTA to HOLMImpulse soon.

One feature request: Support for multichannel devices ie. have the option of selecting which input and output channels are used for measurements. I use the EMU 0404 USB which features 2 channels of analog inputs and outputs and 2 channels of digital S/PDIF inputs and outputs. The digital channels are available as channels 3 and 4 through ASIO and DirectSound. While the digital input is less useful, the output would have been used in many occasions if common measurement software supported multichannel (I know ARTA doesn't).
  Reply With Quote
Old 17th September 2009, 04:33 PM   #410
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: Kona, Hawaii
Blog Entries: 4
Quote:
Originally Posted by askbojesen View Post
Well until I fix the auto post highpass you can highpass the measurement from the options window
Tried that, it does not work well here. Seems the same problem on measurements I take and ones that a friend sends me. Is there some test I can try to verify?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Measuring Frequency Response MCPete Multi-Way 10 10th February 2009 01:36 AM
Measuring Frequency Response furly Planars & Exotics 1 17th March 2006 07:59 AM
Measuring the frequency response of a mic? mr_push_pull Multi-Way 5 30th August 2004 01:26 PM


New To Site? Need Help?

All times are GMT. The time now is 01:16 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2