TSSA V1.6 docs and buyers list - Page 34 - diyAudio
Go Back   Home > Forums > Commercial Sector > Manufacturers > SITO Audio

SITO Audio Dedicated to high Q Current and Voltage FeedBack amps kits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th June 2013, 12:47 PM   #331
diyAudio Member
 
buzzforb's Avatar
 
Join Date: Oct 2010
Location: Burlington, NC
Do you have proper rail voltage?
Have you tried to adjust R10?
__________________
...Shape the sound , Man!
  Reply With Quote
Old 15th June 2013, 12:49 PM   #332
Siberia is offline Siberia  Lithuania
diyAudio Member
 
Siberia's Avatar
 
Join Date: Feb 2011
Location: Vilnius
Rail voltages OK. R10 doesn't help to get voltage on test points. If D1 is not conducting, then it's reasonable.
  Reply With Quote
Old 15th June 2013, 12:54 PM   #333
diyAudio Member
 
buzzforb's Avatar
 
Join Date: Oct 2010
Location: Burlington, NC
Most likely scenario is bad CS Jfet or reversed diode based on my knowledge. If you can access the bottom f the board, you can test the LED with DMM. This assumes all other bjt's are good. Sonny or Salas may be of more help. Not really spent a lot of time figurin circuit workings.
__________________
...Shape the sound , Man!
  Reply With Quote
Old 15th June 2013, 01:10 PM   #334
Siberia is offline Siberia  Lithuania
diyAudio Member
 
Siberia's Avatar
 
Join Date: Feb 2011
Location: Vilnius
The board was assembled and tested by Sonny himself so no reversed parts. Testing D1 with continuity function on DMM shows no signs no matter I approach it. Could it be dead? I could test it with a battery? What voltage?
  Reply With Quote
Old 15th June 2013, 01:18 PM   #335
diyAudio Member
 
buzzforb's Avatar
 
Join Date: Oct 2010
Location: Burlington, NC
Do you have diode setting on your dmm. That is what you need. It will provide it with a little current to turn it on. ANode should be up. o toward positive rail. I have funny feeling it is something else, just dont know the circuit well enough. Clearly you dont have current through that node, which I believe is a Vref for the FE load. Wait and see what Sonny or Salas haev to ay. Sorry I could not help.
__________________
...Shape the sound , Man!
  Reply With Quote
Old 15th June 2013, 01:22 PM   #336
Siberia is offline Siberia  Lithuania
diyAudio Member
 
Siberia's Avatar
 
Join Date: Feb 2011
Location: Vilnius
Well, I have the old board (dysfunctional) here too. Just checked D1 and it turned on with diode setting. That didn't happen on the new board. I suspect D1 as it's an a active part.
  Reply With Quote
Old 15th June 2013, 01:26 PM   #337
diyAudio Member
 
buzzforb's Avatar
 
Join Date: Oct 2010
Location: Burlington, NC
Sounds about right. It should light up just like the other LED. Question is, what cooked it.
__________________
...Shape the sound , Man!
  Reply With Quote
Old 15th June 2013, 01:32 PM   #338
Siberia is offline Siberia  Lithuania
diyAudio Member
 
Siberia's Avatar
 
Join Date: Feb 2011
Location: Vilnius
Very good question. I might try swapping them in my first SMD work attempt. But I'm interested what Sonny has to say on that.
  Reply With Quote
Old 11th January 2014, 05:54 PM   #339
sonnya is offline sonnya  Denmark
diyAudio Member
 
sonnya's Avatar
 
Join Date: Oct 2001
Location: Denmark
After recalculation and lack of response i have decided to sell the tssa V1.6 modules assemblied and tested for 69€/channel.

Ordres are made to:mail@mirand-audio.dk

Best regards

Sonny Andersen
__________________
Mirand Audio amps and Dac's - http://www.mirand-audio.dk
  Reply With Quote
Old 18th June 2014, 07:20 PM   #340
pdb is offline pdb  Denmark
diyAudio Member
 
Join Date: Feb 2007
Location: Bornholm
Great news Sonnya has put up vers. 1.7 at the Vendors Bazaar TSSA V1.7 mosfet Current feedback amp module
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TSSA - The Simplest Symmetrical Amplifier Lazy Cat Solid State 1473 6th July 2014 09:07 PM
TSSA V1.5 sonnya SITO Audio 8 18th June 2014 07:00 PM
All P-channel Regulator For TSSA Split Supply? Jay Solid State 21 14th June 2012 03:16 AM
Philips CDM4 service docs? Pars Digital Source 0 18th August 2007 04:19 PM
Any docs for CDM4/31? till Digital Source 52 10th August 2004 02:16 AM


New To Site? Need Help?

All times are GMT. The time now is 11:21 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright Đ1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2