So nothing is wrong? - diyAudio
Go Back   Home > Forums > Amplifiers > Power Supplies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th March 2013, 12:15 AM   #1
Bando is offline Bando  Canada
diyAudio Member
 
Join Date: May 2012
Location: Stoney Creek, ON
Default So nothing is wrong?

lm1875 psu issues

My previous thread:

Its a SIMPLE psu one to get things going for this amp. Transformer with centre tap ( that is grounded ) to bridge rectifier to soothing caps.


I was able to get two incandence bulb holders with pig tails and hook it up to my PSU. Hooked up as in positive rail to bulb and bulb to ground, same idea for negative rail. It turns out +28 and -27 volts DC at the 40w bulbs with both connected. Same brightness for both bulbs and the positive and negative voltages are on the correct rails. Measurements taken with a Fluke 115 digital volt meter rounded to nearest volt.

Seems right, does it to you?


James
  Reply With Quote
Old 26th March 2013, 03:01 AM   #2
gootee is offline gootee  United States
diyAudio Member
 
Join Date: Nov 2006
Location: Indiana
Blog Entries: 1
Seems OK. What are the voltages with no light bulbs connected (each rounded to nearest 0.01 volt)?

What amp will the PSU be used to power?
  Reply With Quote
Old 26th March 2013, 12:21 PM   #3
Bando is offline Bando  Canada
diyAudio Member
 
Join Date: May 2012
Location: Stoney Creek, ON
The Open circuit voltage is +30.02 and -29.21.

This PSU is to be used with a LM1875. Straight from the ti schematic.
  Reply With Quote
Old 27th March 2013, 03:40 AM   #4
gootee is offline gootee  United States
diyAudio Member
 
Join Date: Nov 2006
Location: Indiana
Blog Entries: 1
Be careful. That is about at the "absolute maximum" supply voltage.
  Reply With Quote
Old 27th March 2013, 06:04 AM   #5
diyAudio Member
 
Join Date: Jun 2011
Some sort of crowbar (for example) protection against voltage peaks could be nice?
Simple solution, 2pcs 30V/5W zeners in parallel with the rails?
  Reply With Quote
Old 27th March 2013, 11:47 AM   #6
Bando is offline Bando  Canada
diyAudio Member
 
Join Date: May 2012
Location: Stoney Creek, ON
I used this transformer because it was handy. Since I am only really looking for 10 or so watts would a 12 volt VCT transformer with a 36 or 24 VA rating be better? Since to me it would logically run cooler and therefore easier to cool. I have read that heat is the main problem with building these amps. As well I would never have a over-voltage situation.
  Reply With Quote
Old 28th March 2013, 03:44 AM   #7
gootee is offline gootee  United States
diyAudio Member
 
Join Date: Nov 2006
Location: Indiana
Blog Entries: 1
I don't know offhand but you can figure it out. You cannot use any voltage you want. The voltage will determine the max rated output power. For a particular load resistance, there is only one supply voltage that will give a particular desired max rated output power level.

Take the transformer secondary's rated RMS output voltage times sqrt(2), i.e. x 1.414, then subtract 1.5 V or so for rectifiers, and that's your nominal rail voltage, Vrail, when under load.

Then subtract the "clipping voltage" from the graph in the LM1875 datasheet (for your loaded-down rail voltage value, Vrail). If there is no graph, use 2.5 to 3 Volts for Vclipping.

Then subtract 10% of Vrail, for the ripple voltage, Vripple. Call the result Vpeak, since it will be the peak signal voltage you can have, when running at max output power.

Then peak output power = Vpeak x Vpeak / Rload. And the maximum continuous RMS output power will be (Vpeak / 1.414 ) x (Vpeak / 1.414 ) / Rload.

For the reservoir capacitance, use

C = [ (1000000 * Vpeak) / (Rload x (Vripple) ) ] * [ (1/(2 * fmains)) + (0.02 / Cap_voltage_rating) ] microfarads,

where Vripple = Vrail - Vclipping - Vpeak, or, Vripple = 0.10 x Vrail .

Since an amplifier is usually only a 1/2 to 2/3 efficient, typically 55% to 65%, use a transformer VA rating that is at least 2X the max RMS output power that you calculated (actually, use 4X, since you calculated for only one channel).

Last edited by gootee; 28th March 2013 at 03:53 AM.
  Reply With Quote
Old 28th March 2013, 11:58 AM   #8
Bando is offline Bando  Canada
diyAudio Member
 
Join Date: May 2012
Location: Stoney Creek, ON
Thanks for the information, though I did do this already half of the calculations myself .

For 12 volts AC the Vrail voltage under load would be 15.49 VDC. According to the graph that would give me a 10w output. I did this part already.

I didn't do the Vclip, Vripple or Vpeak, since the soothing caps I am using are 0.12F, I figured that I didn't need to do those since the caps are so big there wouldn't be any problem. Yes I am being very careful around those caps. As of right now I can not read any AC voltage using my multimeter on the rails under load, it reads 0.022VAC which is background noise to my meter and no 60hz measured.

Thank you for advising me on the VA rating for the transformer. Since my desired output would be 10 watts than I would need a 12v VCT with a VA of 40 at least.

Did I miss something?
  Reply With Quote
Old 29th March 2013, 04:45 AM   #9
gootee is offline gootee  United States
diyAudio Member
 
Join Date: Nov 2006
Location: Indiana
Blog Entries: 1
12 * sqrt(2) = 16.97

16.97 - 1.5 = 15.47 (Vrail)

15.47 - 3 = 12.47 (= Vrail - Vclip) [Important to not skip this step]

12.47 - 0.022 = 12.45 V (Vpeak = Vrail - Vclip - Vripple) [to "calibrate out" the multimeter, short leads and subtract that reading]

12.45 Vpk / sqrt(2) = 8.8 V RMS

8.8 * 8.8 / 8 Ohms = 9.69 Watts RMS

LT-Spice, with everything the same except Schottky diode bridges (and a different discrete transistor amplifier) gives 10.27 Watts RMS and 37 mV ripple.

Last edited by gootee; 29th March 2013 at 04:49 AM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tell me where I'm wrong. raypalmer Multi-Way 37 23rd January 2009 03:16 AM
Wrong Voltage / current on BoZ... or Wrong Measuring ? gionag Pass Labs 8 14th May 2008 11:24 AM
what's wrong with it? bravesz Digital Source 6 27th September 2006 08:15 AM
something wrong? spyder6 Subwoofers 2 21st February 2005 06:58 PM
What am I doing wrong???? Chuck Richey Everything Else 14 17th July 2003 08:42 AM


New To Site? Need Help?

All times are GMT. The time now is 05:23 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2