DPS-600 fast regulated smps for Wire-Amp - Page 11 - diyAudio
Go Back   Home > Forums > Amplifiers > Power Supplies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th November 2012, 05:17 PM   #101
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
AP2,

Can we connect the load from + to - rail, excluding GND ?
  Reply With Quote
Old 5th November 2012, 07:26 PM   #102
qusp is offline qusp  Australia
diyAudio Member
 
qusp's Avatar
 
Join Date: Oct 2009
Location: Brisbane, Australia
this again? just read back a few pages and you'll have your answer
  Reply With Quote
Old 5th November 2012, 07:46 PM   #103
AP2 is offline AP2  Italy
Banned
 
Join Date: Dec 2009
Location: Italy
Quote:
Originally Posted by Workhorse View Post
AP2,

Can we connect the load from + to - rail, excluding GND ?
I already explain this. (if you want use with amplifier) this smps want load on one side at time, even switched very fast. reason that is not good for two amp's,independant of total power.
for test yes, i have tested 10R to -vcc to +vcc at +/-62V. even for 10sec. i not see any problem.
  Reply With Quote
Old 6th November 2012, 12:04 AM   #104
diyAudio Member
 
Join Date: Oct 2011
Location: North West, UK
Blog Entries: 7
Default Wired

Those pics of how it was wired...

Not included the speaker [Mission 78cse 8Ohm] or mains leads.

Ran the setup friday night & saturday night for roughly 2hrs total with the resistors in place. Sunday; removed the resistors and it started fine without the O2/cd player connected. On for roughly 10 seconds before it was turned off. Connected the O2/cd player and turned on source - O2 - dps-600. unit started up then after roughly 6 seconds shut down with both led's blinking.
Attached Images
File Type: jpg thewireamp2.JPG (174.9 KB, 230 views)
File Type: jpg thewireamp4.JPG (128.1 KB, 221 views)
File Type: jpg thewireamp5.JPG (74.5 KB, 213 views)
File Type: jpg thewireamp3.JPG (158.0 KB, 209 views)
File Type: jpg thewireamp6.JPG (106.3 KB, 205 views)
__________________
Listening with Gusto!
  Reply With Quote
Old 6th November 2012, 10:29 AM   #105
AP2 is offline AP2  Italy
Banned
 
Join Date: Dec 2009
Location: Italy
Good table..eheh.
Some advice independant of all:
HeatSink is better connect to base panel of dps-600.
Connect heart of dps-600 (see my old pic for this) it is necessary,specially in this your connections.
Bias measurements:
in the measurement of bias, considered that the flow is transverse (not affected the load (speaker).
At 400mA,with your voltage setup, wire-amp dissipate 38-40w (only Mosfet) ..simple info.

Last edited by AP2; 6th November 2012 at 10:59 AM.
  Reply With Quote
Old 6th November 2012, 11:36 AM   #106
diyAudio Member
 
Join Date: Oct 2011
Location: North West, UK
Blog Entries: 7
Thanks, I'll implement those changes before doing enything else, plus add the standby switch. I will back off the bias and adjust anew...

Quote:
Originally Posted by AP2 View Post
ah .. well! This is a special extra protection in the event fails the power regulator, just not to damage the amp, or other devices associated with the DPS-600.
I honestly do not understand how it can happen.
If you are able to replace the one mosfet smps, I can send, or you buy it, and I will refund.
looks like you have some damaging loop. in this case it is preferable that lowers the bias current, just to investigate the noise.
Am I looking to replace Q2, Q3, Q5... or something else?

Quote:
have replaced the res-fuse on the first smps?
Not yet, the diode under the LM317 appears to be no good also, I'll replace it & the reg to be on the safe side.
__________________
Listening with Gusto!
  Reply With Quote
Old 6th November 2012, 11:49 AM   #107
AP2 is offline AP2  Italy
Banned
 
Join Date: Dec 2009
Location: Italy
Only Q2 need to change. (In reality, the dps-600 works for 1 sec., the supervisor break because the output voltage is higher than 20%)
For diode i not think, it is 3Amp also. 1R-Fuse save all in this area.
i send pm today later for disassemble Q2.

Last edited by AP2; 6th November 2012 at 12:13 PM.
  Reply With Quote
Old 6th November 2012, 12:14 PM   #108
diyAudio Member
 
Join Date: Oct 2011
Location: North West, UK
Blog Entries: 7
Right just Q2 [1 X IRFP250], had a quick look does it need to be 200V 33A or possible to use 200V 30A?

Thanks again, I WILL get it all working & trouble free
__________________
Listening with Gusto!

Last edited by BuildMeSomething; 6th November 2012 at 12:24 PM.
  Reply With Quote
Old 6th November 2012, 01:37 PM   #109
diyAudio Member
 
Workhorse's Avatar
 
Join Date: Dec 2004
Quote:
Originally Posted by AP2 View Post
I already explain this. (if you want use with amplifier) this smps want load on one side at time, even switched very fast. reason that is not good for two amp's,independant of total power.
for test yes, i have tested 10R to -vcc to +vcc at +/-62V. even for 10sec. i not see any problem.
What if 2 half bridge amplifier modules are connected to this smps and configured in bridge configuration, in that case the LOAD CURRENT will pass thru + to - rail without going into GND. Will it have same regulation or something different is expected?
This was the reason for asking again.
  Reply With Quote
Old 6th November 2012, 02:05 PM   #110
qusp is offline qusp  Australia
diyAudio Member
 
qusp's Avatar
 
Join Date: Oct 2009
Location: Brisbane, Australia
umm do you think we could keep this to discussion of this supply with THIS amplifier as mentioned in the subject? how praytell is this productive?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Simple regulated SMPS for my Ghettoblaster (pics) Lope Power Supplies 1 10th June 2011 12:20 AM
Fast capacitors for SMPS Joshua_G Power Supplies 6 14th July 2010 09:06 PM
fast versus schottky diodes for smps jamesrnz Power Supplies 8 4th September 2008 12:42 AM
Regulated or non-regulated SMPS longitude Class D 5 8th May 2007 04:02 PM
SMPS regulated output MaXiZ Power Supplies 1 24th December 2005 09:10 AM


New To Site? Need Help?

All times are GMT. The time now is 10:09 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2