Polytone power supply rehab..can u help? - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Power Supplies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th July 2012, 12:09 AM   #11
diyAudio Member
 
Join Date: Jul 2012
Yea..sounds logical...but when you place the cap down onto the board, those holes are really no where near the lead that is dangling...the lead actually looks like it was soldered to the resistor that is there..anyway..that is where it lines up when you hold the cap in place. When i replace the transistors, i will pull off the board and look at the other side to see if there are clues...a friend of mine has the same exact amp ...im trying to get him to open his up to see if he has the same thing goin on...but he's a afraid to pull it out...
  Reply With Quote
Old 11th July 2012, 08:33 AM   #12
diyAudio Member
 
Join Date: Aug 2010
Your schematic did not post.

It looks to me like there is solder rosin by the resistor lead and hard to see but the solder looks flat on the end of the cap like it was spread out on the pcb next to the resistor. So the cap was probably tacked to the side of the resistor lead.
  Reply With Quote
Old 11th July 2012, 04:31 PM   #13
diyAudio Member
 
Join Date: Jul 2012
I think you are correct...it lines up almost perfectly. There is some solder on the resistor lead also....i could see that falling off...just wish one of these schematics showed this...they all show CR1 and give no data on it. I tried to upload the schem again...maybe its being filtered out?
  Reply With Quote
Old 16th July 2012, 06:08 AM   #14
diyAudio Member
 
Join Date: Jun 2012
Quote:
Originally Posted by CHARLIE X View Post
Hi, I am new to the group and love the sound of my Polytone baby Taurus with 8 inch speaker. This thing is old now (like me) so I would think its not too hard to make a "Polyclone' of this thing. I have some electronics background, but never built an amp before...not great at translating the schematic to a PCB. Can anyone recommend a starting point? A book or something to get started with cleaning up this power supply? Its now full of pops and buzzes...probably needs new filter caps...i dont even know which things on the board are the filter caps...or what they do. So..thats where im at. Anybody ?
Well actually, if you are hearing buzz, especially 120 cycle, there is a pretty fair chance you do have a bad transistor, or diode, not that changing the old electrolytic capacitors will help also...
pops can be dirty controls and jacks, or bad solder connections.
The transistors in these amps need to be changed fairly frequently, I suppose they run hot and there is a lack of thermal management.
You can add some better heat sinks, newer packages, or use insulators to mount the new transistors / packages to the chassis...
or just change them now and again, anyhow they blow.
I have no idea what to change them to, as far as substitutions, there have not been many of these Polytones around for a number of years.
There "should " be some substitute matched pairs that you could use...
anyhow, when they do work, they sound good for a clean sound. I never liked the built in distortion on these amps.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speaker impedance for polytone 6stringer Instruments and Amps 0 23rd March 2012 09:30 PM
Power supply positive-negative-ground from a single power supply mome Power Supplies 8 9th September 2011 05:17 PM
Polytone Power Amp Oscillation ben-horne Solid State 8 17th March 2008 11:08 PM
problem with polytone amp jcspurs Solid State 8 6th November 2007 12:06 PM
rehab old genesis II's genesisII Multi-Way 5 16th January 2006 04:10 PM


New To Site? Need Help?

All times are GMT. The time now is 02:37 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2