LTspice simulation - diyAudio
Go Back   Home > Forums > Amplifiers > Power Supplies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th May 2012, 12:20 PM   #1
diyAudio Member
 
Join Date: May 2012
Default LTspice simulation

I am designing a 1.5 KW power supply and 1000 volt output .input is 50V DC.Now I am designing the circuit in LTspice . But I can't get the desired output. I think that my circuit has some problems. can anybody help me to correct it?
Attached Files
File Type: zip LTSpice for power suply.zip (97.0 KB, 11 views)
  Reply With Quote
Old 25th May 2012, 12:51 PM   #2
PChi is online now PChi  United Kingdom
diyAudio Member
 
Join Date: Jan 2012
Location: Staines, UK
Some comments on the circuit are:-

At 1000 W at 50 V the input current = 20 A. I don't know why R21 to R24 are included which are shown as 1 ohm.

Any imbalance in the pulse widths causes a DC current through the transformer which could be a problem in a real circuit. Sometimes fixed by adding a series capacitor or using a current mode control IC.

The sensing feedback is connected to the rectifier diode side of the inductor. I would have expected it to be connected to C1.

The TL431 is a cheap and dirty feedback error amplifier but gives limited flexibility in seting the frequency compensation.

C1 is a low value. It that correct?
  Reply With Quote
Old 28th May 2012, 03:02 PM   #3
diyAudio Member
 
Join Date: May 2012
I corrected the scematic and I got the desired result. What suggestions do you have to be more complete circuit?
Attached Files
File Type: asc Draft2.asc (10.5 KB, 13 views)

Last edited by 8409513; 28th May 2012 at 03:18 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Distortion simulation with LTspice tiagor Solid State 32 22nd December 2012 09:33 PM
How to do IMD simulation in LTspice!!! nicholas1113 Solid State 30 16th January 2010 01:15 AM
About LTSpice Simulation. nicholas1113 Solid State 2 15th November 2009 07:52 AM
LTSpice Simulation template?! ipop07 Tubes / Valves 5 13th May 2009 06:17 PM
LTSpice PSU simulation help - SoftStart modeling ninjanki Power Supplies 10 21st March 2005 04:04 PM


New To Site? Need Help?

All times are GMT. The time now is 08:20 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2