blowing fuse on power cable - diyAudio
Go Back   Home > Forums > Amplifiers > Power Supplies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th November 2011, 06:57 PM   #1
diyAudio Member
 
Join Date: Nov 2011
Exclamation blowing fuse on power cable

putting my sub and amp into my car earlier and when i went to connect my power cable up last it keeps blowing the fuse on the power cable from battery to amp. now my cd player wont turn on at all and none of the radio fuses have blown on the fues board. any ideas??
  Reply With Quote
Old 25th November 2011, 07:00 PM   #2
diyAudio Member
 
Join Date: Dec 2010
Location: wigan
what rating is the fuse that keeps blowing.

did the amplifier work before it was installed in you car
  Reply With Quote
Old 25th November 2011, 07:18 PM   #3
diyAudio Member
 
Join Date: Nov 2011
its a 10amp fuse, and yes the amp used to work, i tried a 30amp fuse too and it blew straight away aswell
  Reply With Quote
Old 25th November 2011, 08:15 PM   #4
diyAudio Member
 
Join Date: Dec 2010
Location: wigan
Hi again.

Ther maybe a short in the power cable. is the fuse in the amplifier ok
  Reply With Quote
Old 25th November 2011, 10:21 PM   #5
diyAudio Member
 
Join Date: Nov 2011
All the fuses are dead on. Think il buy a new wiring kit then try it. Cd played won't turn on now but and fuse in it is ok too
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Peavey 400 blowing fuse on power up Barnacle Solid State 11 2nd February 2009 10:49 AM
fosgate 1998 series power 500.2 amp blowing fuse jbrooksgametech Car Audio 13 26th November 2008 06:21 PM
Fuse housing melting but fuse not blowing, ppi amp rawadia Car Audio 21 2nd August 2008 10:39 AM
Blowing my fuse (s) Jimlondon Chip Amps 7 7th March 2005 06:03 PM
Amp intermittently blowing fuse at power up Saurav Tubes / Valves 11 10th January 2005 12:21 AM


New To Site? Need Help?

All times are GMT. The time now is 06:47 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2