diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Power Supplies (http://www.diyaudio.com/forums/power-supplies/)
-   -   need help with blown mosfets..plz.... (http://www.diyaudio.com/forums/power-supplies/191108-need-help-blown-mosfets-plz.html)

saadkhangul 18th June 2011 11:39 PM

need help with blown mosfets..plz....
 
hi everyone.... i would really appreciate any help. my amp shorted cuz a little water went it it. i saw blown mosfets and resistors. i saw a few videos and thought it would be a piece of cake so, i replaced all six irfz44n mosfets and resistors. now when i hook it up the amp turns green and the power wires get hot like crazy and start to smoke and the mosfets get really hot too but the audio comes on and after about 15 seconds the amp goes into protect . is the amp still shorted??? plz guide me to test the amp for shorts as im relatively new to electronics. thanx in advance

saadkhangul 19th June 2011 12:29 AM

also the insulator of audio side transistors lost and they are in direct contact with body.. can this cause the short??

nigelwright7557 19th June 2011 12:36 AM

Could be you have blown the driver components too.
Check the driver transistors for shorts.

saadkhangul 1st July 2011 08:14 AM

plz everyone i need valuable advice..... 58 views and only one suggestion?? plz reply

Radugazon 1st July 2011 08:47 AM

No panic...you have to check every stage methodically, first the power supply : deconnect it from the board and check if it's symmetric. Then, if you don't found an evident short (as you said, if the micas are gone !!!), try the amp but with only one channel supplied at once. Cut the tracks if necessary. Like this you will see better what's wrong.


All times are GMT. The time now is 09:07 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2