Small PSUs breaking all the time - diyAudio
Go Back   Home > Forums > Amplifiers > Power Supplies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th July 2009, 07:10 AM   #1
akis is offline akis  United Kingdom
diyAudio Member
 
Join Date: Jul 2008
Default Small PSUs breaking all the time

In the past year I have had 4-5 PSUs breaking/blowing/melting. The first was supposed to deliver 2.5 Amps at 5 VDC to power the wireless access point in the loft. I appreciate the loft is quite inhospitable, but the designer of the PSU should have included heat/cold in the parameters. That was a USRobotics5450. I made my own PSU, it is 3 times the size, not switched you see, but works cool.

Then we got another 3 or 4 PSUs blowing, the all-in-one-with-plug types. Sure they were plugged in all day, but why get so hot and why melt? The latest one made some loud cracking noises, which I thought was the cat, instead it was the PSU of my cable modem, been in service for more than 4-5 years and always on. The plastic outside has melted, no idea what the inside looks like.

In general, those PSUs all run quite hot, at 22-25 C ambient, excepting the one in the loft, and I cannot understand why they break after a few years (or months). These are PSUs that we leave plugged in permanently - they power the routers, the modems, the answer phones etc.

I am thinking this is serious fire hazard (since it managed to melt the plastic) and as they run hot and can blow at any time then you are never safe.

Any thoughts?
  Reply With Quote
Old 24th July 2009, 01:15 PM   #2
star882 is offline star882  United States
diyAudio Member
 
star882's Avatar
 
Join Date: Mar 2007
They're undersized for the load.
__________________
"Fully on MOSFET = closed switch, Fully off MOSFET = open switch, Half on MOSFET = poor imitation of Tiffany Yep." - also applies to IGBTs!
  Reply With Quote
Old 24th July 2009, 01:33 PM   #3
diyAudio Member
 
Frank Berry's Avatar
 
Join Date: Sep 2003
Location: Midland, Michigan
Most of these "Wall Warts" are not rated for continuous duty.
The transformers get too warm. The heat dries out the electrolytic and it eventually shorts ... taking the rectifiers and transformer with it.
They can be a fire hazard.
A good rule of thumb is never to draw more than 50% of the Wall Wart current rating.
__________________
Frank
  Reply With Quote
Old 24th July 2009, 03:08 PM   #4
akis is offline akis  United Kingdom
diyAudio Member
 
Join Date: Jul 2008
Manufacturers trying to cut down on costs... Nothing the consumer can do. It is appalling and should be authorities action on this.

Test: buy brand new device. Plug in for 1 hour. Touch PSU - if more than 40 C (in a 25 C ambient ) then there is an issue (it will be hotter inside).
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Breaking in your tubes? Lingwendil Tubes / Valves 3 6th June 2009 04:48 AM
Breaking In a new set of Speakers MellowTone Multi-Way 12 19th July 2006 09:29 AM
First time horn help.. small footprint Matt@Nearfield Multi-Way 2 17th May 2005 02:55 PM
whats a good time for breaking in tubes karma Tubes / Valves 2 14th May 2003 06:51 PM
Breaking-in a subwoofer BAM Subwoofers 5 21st November 2001 12:59 AM


New To Site? Need Help?

All times are GMT. The time now is 02:49 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2