MC34063 blues - diyAudio
Go Back   Home > Forums > Amplifiers > Power Supplies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th June 2009, 03:25 AM   #1
diyAudio Member
 
astouffer's Avatar
 
Join Date: Jun 2004
Location: Pittsburgh, crumbling wasteland
Default MC34063 blues

Can anyone help me figure out why this circuit with an MC34063 is not working correctly? I followed the datasheet and also used the design tool to try and boost 12 volts up to 20.

Without a load the voltage slowly creeps up to about 18 and then drops with even a few milliamps applied. My first inductor was a 100uH toroid which I thought was too low so I changed it for a 250uH ferrite core choke. Then I lowered the timing cap from 220pF to 100pF to increase the switching frequency, that also had little effect.

Any ideas as to whats wrong?
Attached Images
File Type: gif mc34064_sch.gif (40.0 KB, 191 views)
  Reply With Quote
Old 12th June 2009, 03:28 AM   #2
diyAudio Member
 
astouffer's Avatar
 
Join Date: Jun 2004
Location: Pittsburgh, crumbling wasteland
Here is the pcb layout in case thats an issue. Red is the top layer and blue is the bottom.
Attached Images
File Type: gif mc34064_pcb.gif (21.8 KB, 147 views)
  Reply With Quote
Old 12th June 2009, 03:41 AM   #3
star882 is offline star882  United States
diyAudio Member
 
star882's Avatar
 
Join Date: Mar 2007
The inductor needs to connect before the 180R resistor.
__________________
"Fully on MOSFET = closed switch, Fully off MOSFET = open switch, Half on MOSFET = poor imitation of Tiffany Yep." - also applies to IGBTs!
  Reply With Quote
Old 12th June 2009, 02:23 PM   #4
diyAudio Member
 
astouffer's Avatar
 
Join Date: Jun 2004
Location: Pittsburgh, crumbling wasteland
Doh!

Many thanks, thats been bothering me for a while.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Blues. steenoe Music 179 12th September 2011 03:19 AM
Trends Ta- 10 blues... merlin2069er Class D 2 21st July 2009 03:40 PM
The 120Hz Blues... kff322 Tubes / Valves 2 24th February 2008 07:26 PM
KT-77 Blues TubeHead Johnny Tubes / Valves 0 26th February 2007 02:31 AM
DIY Blues Chad Solid State 2 25th October 2001 04:34 AM


New To Site? Need Help?

All times are GMT. The time now is 01:38 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2