Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Simplistic Mosfet HV Shunt Regs
Simplistic Mosfet HV Shunt Regs
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st January 2012, 07:30 PM   #2571
dadedady is offline dadedady  Greece
diyAudio Member
 
Join Date: Sep 2011
Location: Athens-Greece
Hi Salas.
Do you think that BF245A is les drifty than 2SK170 (for SSHV2).
  Reply With Quote
Old 21st January 2012, 07:37 PM   #2572
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Simplistic Mosfet HV Shunt Regs
Yes, but try only the lowest IDSS one you got as it has the lowest pinch off also. If pinch off (Vgs OFF) isn't lower than (-) 0.6V then its not working optimally here.
  Reply With Quote
Old 22nd January 2012, 02:04 AM   #2573
j45yip is offline j45yip  Singapore
diyAudio Member
 
Join Date: Sep 2004
Location: Singapore
Quote:
Originally Posted by regal View Post
Nice I have a similar SSHV1 but with WE417A (close cousin to your tube.) Also in the proces of upgrading, but I am just going to make a new amp module, parafeed this time. Interested to know what OPT you are using as the SSHV's handling of inductance is always called into question?
...the SSHV1 is powering my 5687 wot pre with LL1660 as well and have no issues whatsoever...brought it to another level.
  Reply With Quote
Old 23rd January 2012, 07:43 AM   #2574
king4joy is offline king4joy  Hong Kong
diyAudio Member
 
Join Date: Apr 2011
I need a SSHV2 board soon as GB is available.

My P-P SSHV2 is not in working order.....when connected to a 10K dummy load....the LED does not light up....
Attached Images
File Type: jpg P1120006.JPG (36.2 KB, 386 views)
  Reply With Quote
Old 23rd January 2012, 07:48 AM   #2575
king4joy is offline king4joy  Hong Kong
diyAudio Member
 
Join Date: Apr 2011
I need a SSHV2 board soon as GB is available.

My P-P SSHV2 is not in working order.....when connected to a 10K dummy load....the LED does not light up....
  Reply With Quote
Old 23rd January 2012, 07:52 AM   #2576
king4joy is offline king4joy  Hong Kong
diyAudio Member
 
Join Date: Apr 2011
Sorry....I do not mean to post twice....I must have pressed the wrong button again twice....or something....sorry...
  Reply With Quote
Old 23rd January 2012, 07:56 AM   #2577
vgeorge is offline vgeorge  Greece
diyAudio Member
 
vgeorge's Avatar
 
Join Date: Mar 2004
Location: poros island
Simplistic Mosfet HV Shunt Regs
Have you checked your CCS first?
What is you voltage acroos R5?
  Reply With Quote
Old 23rd January 2012, 08:03 AM   #2578
king4joy is offline king4joy  Hong Kong
diyAudio Member
 
Join Date: Apr 2011
I disconnect in a hurry b/4 and sond, smoke, snd smell....

I have checked the p-p, they seem OK....but I will check again...
  Reply With Quote
Old 23rd January 2012, 08:14 AM   #2579
king4joy is offline king4joy  Hong Kong
diyAudio Member
 
Join Date: Apr 2011
I will need to wait till tomorrow before I can connect it again.....when I connect it again, what should I measure.....in order of important because it could be brief.....and I can only do it so quickly before smell comes....I guess.....
  Reply With Quote
Old 23rd January 2012, 08:15 AM   #2580
vgeorge is offline vgeorge  Greece
diyAudio Member
 
vgeorge's Avatar
 
Join Date: Mar 2004
Location: poros island
Simplistic Mosfet HV Shunt Regs
Smoke and smell, probably some semis are damaged.
Check them first before firing again.

Last edited by vgeorge; 23rd January 2012 at 08:18 AM.
  Reply With Quote

Reply


Simplistic Mosfet HV Shunt RegsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Regs - Shunt vs Series richie00boy Solid State 59 17th June 2017 03:59 PM


New To Site? Need Help?

All times are GMT. The time now is 08:33 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki