Please help me check,Can this dual power use tl431 and a op work well? - diyAudio
Go Back   Home > Forums > Amplifiers > Power Supplies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th November 2008, 05:48 AM   #1
diyAudio Member
 
Join Date: Nov 2008
Default Please help me check,Can this dual power use tl431 and a op work well?

Hello, i am a newbie
i try to use tl431(lm431) to make a dual power(pos and neg dc) supply for OP that can replace 78xx 79xx lm317 and lm137 series
due to i think tl431 have better temputure performance than them,and tl431 is cheap
sorry for my english, too bad and too many wrong spell but i believe that you can understand

i don't know how to use tl431 for negtive power , i was confused, infact i design one, but use spice simulate, it can not keep the voltage, with the changes of RL(the load resitense) ,the voltage is change,so that can not fit my needs

then i found fairchild 78xx manual have a tracking voltage regulator schemitic that useing a OP and a PNP to just tracking and follow the Positive voltage,
so i use the typical TL431 plus a NPN postive regulator diagram and mix with the tracking way make this one
please see the pic i upload
  Reply With Quote
Old 17th November 2008, 03:56 AM   #2
dtproff is offline dtproff  United States
diyAudio Member
 
Join Date: Oct 2008
Location: Plano, TX, USA
Sorry Charlie...

This really won't work. You need some type of switching element to generate the negative rail

The simplest form is a switched capacitor inverter (Charge pump). These are good for small power applications only (~20mA range) For larger currents you will need an inductor and a DC/DC converter.

Take a look at somem of the TI parts. One off the top of my head is the TPSTPS54353. But their are a lot of chinese and Taiwan versions available also.

http://focus.ti.com/lit/ds/symlink/tps54353.pdf

Sorry... I hope that helps.

Tony
  Reply With Quote
Old 18th November 2008, 09:05 AM   #3
diyAudio Member
 
Join Date: Nov 2008
thanks
and due to i am newbie and not familiar the forum, i duplex post this at here:
http://www.diyaudio.com/forums/showt...97#post1658197

the pic is at here
http://www.diyaudio.com/forums/attac...amp=1226557423
and change the Q2 to PNP and swap the Pin 2 and Pin 3 (inverting and non-inverting input of OP LM741) then it works ok!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please check my work :) athos56 Tubes / Valves 11 17th August 2008 07:05 AM
please check my work gary h Tubes / Valves 10 10th August 2008 10:52 PM
Pentode CCS: Would somebody check my work? nullspace Tubes / Valves 5 13th March 2007 05:26 PM
TL431 for TDA1541 does not work Bernhard Digital Source 7 26th January 2004 09:56 PM
ELF (Check my work, please) fortyquid Subwoofers 4 1st October 2003 07:48 PM


New To Site? Need Help?

All times are GMT. The time now is 05:28 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2