Go Back   Home > Forums > Loudspeakers > Planars & Exotics

Planars & Exotics ESL's, planars, and alternative technologies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th February 2005, 11:08 PM   #1
diyAudio Member
 
rob_deas's Avatar
 
Join Date: Jan 2004
Location: UK
Default Quad ESL 57 mains voltage problem

My beloved ESL 57s have just joined me in Toronto after several weeks on a container ship. I have been trying to change the mains voltage control on the back from 240V to 110V so I can use them but it won't turn at all. Does anyone know how to do this? Is the knob supposed to just turn, or does it pull out and turn or push in and turn? I've tried using as much force as fingers can exert without having any effect on it - I'm loathe to use something like pliars until I know how it operates. Can anyone help?
Rob
  Reply With Quote
Old 21st February 2005, 06:21 AM   #2
frugal-phile(tm)
diyAudio Moderator
 
planet10's Avatar
 
Join Date: Oct 2001
Location: Victoria, BC, NA, Sol III
Blog Entries: 5
Un North America they all had to be fixed at 110V. IIRC -- and the 303s i've seen that snuck over are the same -- you pull the plug out, totate it, and plug it back in....

Maybe some of the Euro members can chime in with less fuzzy info...

dave
__________________
community sites t-linespeakers.org, frugal-horn.com, frugal-phile.com ........ commercial site planet10-HiFi
p10-hifi forum here at diyA
  Reply With Quote
Old 21st February 2005, 04:37 PM   #3
diyAudio Member
 
rob_deas's Avatar
 
Join Date: Jan 2004
Location: UK
Default I think that's it

Thanks for the help. I think that's right, someone on audioasylum posted the same thing: pull it out, turn it to the correct voltage, push it back in again, apparently it's a two-pin plug. I'll try it tonight.
Rob
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quad 405 mains transformer? Confussed Solid State 2 14th August 2007 06:12 PM
Weird Quad II mains transformer help hd38 Tubes / Valves 2 12th June 2007 02:36 PM
BBC modded Quad 405s - mains hum spwyatt Solid State 4 2nd October 2006 09:18 AM
Quad II mains transformer 405man Swap Meet 1 19th January 2004 05:49 PM
QUAD II mains at 240VAC instead of 220VAC? Zombie Tubes / Valves 4 20th February 2003 04:59 PM


New To Site? Need Help?

All times are GMT. The time now is 11:05 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2