Licron Crystal lifetime? - diyAudio
Go Back   Home > Forums > Loudspeakers > Planars & Exotics

Planars & Exotics ESL's, planars, and alternative technologies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th August 2015, 10:05 AM   #1
diyAudio Member
 
Join Date: Aug 2010
Default Licron Crystal lifetime?

Those of you who had tried out Licron Crystal, for how long have you had the bias voltage on since you coated your panels?

Just write down your experience.
1. How many hours have they been powered?
2. Bias voltage?
3. Spacing?
4. If you have had breakdowns, do you know the root cause?

From what i understand the oldest panel is about 12 years old by now?
I have not tried it myself, i must be the last one...
Martin
  Reply With Quote
Old 29th August 2015, 11:54 AM   #2
diyAudio Member
 
CharlieM's Avatar
 
Join Date: Feb 2008
Location: Savannah, GA
I first started using Licron Crystal 7 years ago. However, I've replaced my panels twice during that time, experimenting with different stator materials and segmentation. My most used panel (not currently using it) played about10 hours per week on average for about 5 years. The d/s spacing was .062 and bias voltage 2.7KV. Power to the bias supply was switched from the preamp so only on when the system was on. I never had any problems with the panels or noticed any degradation.
  Reply With Quote
Old 30th August 2015, 04:37 AM   #3
SyBorg is online now SyBorg  United States
diyAudio Member
 
Join Date: Dec 2012
Location: Redondo Beach, CA
I've had one set of ESLs using Licron Crystal that I have had powered continuously for about 3 years. Have not noted any degradation or other issues. d/s 0.062, bias 3.2kV. All the others are newer or have been only powered during the listening time.
  Reply With Quote
Old Yesterday, 06:46 PM   #4
diyAudio Member
 
bolserst's Avatar
 
Join Date: Jun 2005
Location: Fort Worth, Texas
I have built many sets of ESLs using Licron Crystal with > 5 years on them, none showing any change in sensitivity.
Most were D/S = 0.07 in. with 3.5kV, however there are two full range panels using D/S = 0.12 with 5.2kV.
Most are setup to switch on and off with the preamp, however there are some where the HV is left on all the time.

The only failures of Licron Crystal conductivity I know of were related to prolonged exposure to direct sunlight.
Licron Crystal, and many other conductive coatings, are not 100% UV resistant.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
group buy Licron Crystal ESD coating [NL -DE-BE] WrineX Planars & Exotics 22 22nd August 2015 05:18 PM
Licron coating methods DeltaStar Planars & Exotics 6 23rd March 2015 07:51 PM
Here's a one in a lifetime chance for a bargain! SemperFi Instruments and Amps 3 2nd November 2011 02:07 AM
Techspray Licron Crystal WrineX Planars & Exotics 10 4th September 2010 12:18 AM
Tube lifetime roland bios Tubes / Valves 4 13th January 2008 05:31 PM


New To Site? Need Help?

All times are GMT. The time now is 06:13 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2