Martin Logan Aerius i HT Board Transformer Kaputt !? - Page 3 - diyAudio
Go Back   Home > Forums > Loudspeakers > Planars & Exotics

Planars & Exotics ESL's, planars, and alternative technologies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th October 2013, 08:57 PM   #21
diyAudio Member
 
Join Date: Jun 2011
you can see difference in terminals....
faulty board has 4 /5 connections, replacement only 2

aerius boards 2.jpg

aerius boards.jpg

Last edited by alaneglinton; 7th October 2013 at 09:06 PM.
  Reply With Quote
Old 8th October 2013, 10:56 PM   #22
diyAudio Member
 
bolserst's Avatar
 
Join Date: Jun 2005
Location: Fort Worth, Texas
Quote:
Originally Posted by alaneglinton View Post
The transformer has exactly the same readings on both 103 and 102 boards so don't think that's my problem any more that's why I switched the whole board.
When you say "same readings", what do you mean? are you measuring voltages at the secondary terminals of the transformer when the supply is powered up that match those of the 102 board and your other 103 board? If so, I guess I don't understand what you meant in your initial post when you said you had narrowed down the problem to an open winding in the transformer.

Taking a step back...had you tried swapping the power supplies(or panels) between your working and non-working speaker to verify that it is the power supply and not the panel that is the problem?
  Reply With Quote
Old 9th October 2013, 09:15 PM   #23
diyAudio Member
 
Join Date: Jun 2011
Quote:
Originally Posted by bolserst View Post
When you say "same readings", what do you mean? are you measuring voltages at the secondary terminals of the transformer when the supply is powered up that match those of the 102 board and your other 103 board? If so, I guess I don't understand what you meant in your initial post when you said you had narrowed down the problem to an open winding in the transformer.

Taking a step back...had you tried swapping the power supplies(or panels) between your working and non-working speaker to verify that it is the power supply and not the panel that is the problem?
By same readings I meant resistance
Turned out my 'open winding' on the 103 was also open on the 102 board I know works so I obviously didn't measure across the right terminals in the first place.

I have already swapped 103 PCB's across speakers and the fault moved with the board so I am 100% sure the board is the issue.

Looks like I can go with the connections as I planned given feedback from forum and ML - will try tomorrow and report back
  Reply With Quote
Old 10th October 2013, 02:42 AM   #24
diyAudio Member
 
bolserst's Avatar
 
Join Date: Jun 2005
Location: Fort Worth, Texas
Quote:
Originally Posted by alaneglinton View Post
I have already swapped 103 PCB's across speakers and the fault moved with the board so I am 100% sure the board is the issue.
Good to hear.
Replacement panels are more costly than HV supplies and more difficult to DIY repair.
Let me know if you are interested in trying to repair your 103 HV supply.
I can send you some troubleshooting steps to narrow down where the fault lies.

Quote:
Looks like I can go with the connections as I planned given feedback from forum and ML - will try tomorrow and report back
Oh, I forgot to comment on the strategy you mentioned in post#19 for connecting your 3 ground wires to the 102 PCB.
I think your proposed connections should work just fine.
  Reply With Quote
Old 12th October 2013, 03:20 PM   #25
diyAudio Member
 
Join Date: Jun 2011
Default All good !

Quick Update...

New board fitted and wired as per posts here and everything now works superbly well !
Very happy and thanks to everyone for the great advice...

  Reply With Quote
Old 6th January 2014, 01:10 AM   #26
FPN is offline FPN
diyAudio Member
 
Join Date: Jun 2013
Default Aerius HV transformer.

Guys,

I also have problem with Aerius HV transformer on HT Board on both speaker.
I try to source the similar type but can't find here, some electrician say this is a customize model by ML.
Please let me know if anyone able to help me get the HV transformer (new/second hand) and willing to send to Indonesia.
You can PM me.

Thanks.

FPN.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recoating Martin Logan Aerius Panel FPN Planars & Exotics 40 27th January 2014 06:19 AM
Martin Logan Aerius fuse Sandor Planars & Exotics 1 29th June 2013 09:09 AM
Help Martin Logan janbb Planars & Exotics 6 4th November 2012 06:53 PM
Martin Logan Aerius i panel removal servasol Planars & Exotics 4 1st December 2011 06:40 PM
Repair of Martin Logan Aerius i jorn Planars & Exotics 3 4th April 2010 03:50 PM


New To Site? Need Help?

All times are GMT. The time now is 02:25 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2