diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Planars & Exotics (http://www.diyaudio.com/forums/planars-exotics/)
-   -   Help with ESL-63 (http://www.diyaudio.com/forums/planars-exotics/218031-help-esl-63-a.html)

boafff 16th August 2012 04:18 PM

Help with ESL-63
 
Hello all,

First post here. Looks like a great site with lots of useful information, and helpful users. I have owned a pair of Quad ESL 63 for many years, and they have spent half of their lifetime in repair and storage, but now I have moved in to a house big enough to accomodate them and I would like to bring them back to life again. But unfortunately one speaker is not producing any sound with the power on (sound level is the same with or without power on). I donwloaded the service manual and wanted to see follow the troubleshoot procedure, but the photos are too dark to be of any help. Can someone give me a clue?? I donīt really want to send it out to repair, as this will probably mean months before I get it back again... The panels do not produce any hissing or popping sound at least, so it seems to me that the panels are OK.

Thanks

esl 63 9th October 2012 10:36 PM

Ok... First is the power on LED shinin?
Not far from there there is a hole maybe 4mm with a rubber plug.
Remove the plug and count how many blinks you get from the neon bulb per minute.

boafff 23rd October 2012 01:23 PM

Thanks for the reply.... So it is unfortunately not blinking at all... I tried with the other speaker and it blinks at a rate of about 9 times per minute... Never noticed that rubber plug before...


All times are GMT. The time now is 08:07 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright Đ1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2