Parts for the Quad ESL 63 - diyAudio
Go Back   Home > Forums > Loudspeakers > Planars & Exotics

Planars & Exotics ESL's, planars, and alternative technologies

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd January 2003, 04:34 PM   #1
Buhl is offline Buhl  Denmark
diyAudio Member
 
Buhl's Avatar
 
Join Date: May 2002
Location: Aalborg, Denmark
Default Parts for the Quad ESL 63

Hi There
My beloved Quads i beginning so show the effects of the previous owners tweak attempts - the dustcovers has been removed, and I think this is why one of them is beginning to play lower (abaout 6-8 dB I would guess) than the other - I suspect that some of the panels has been shortet

I have heard that quad does not supply parts anymore - does anybody know if and where I can buy mylar and conductive spray, so I can attempt to get the speakers back in good condition ???

Or should I forget about it, at get startet on a set of Proac 2.5 clones ???


Cheers !

Hans
  Reply With Quote
Old 23rd January 2003, 04:58 PM   #2
diyAudio Member
 
analog_sa's Avatar
 
Join Date: Aug 2002
Location: Sofia
It's been years since i last had anything to do with electrostats and my advice may be quite rusty. It's unlikely anything is shorted. Can you check that your high voltage is ok? And all the panels are getting it? If yes, the mylar is probably not holding the charge any more. I've successfully used colloid solution of carbon dust or various antistatic sprays. Opening the panels will allow you to inspect the mylar for pin-holes as well.

good luck

peter
  Reply With Quote
Old 23rd January 2003, 05:13 PM   #3
Buhl is offline Buhl  Denmark
diyAudio Member
 
Buhl's Avatar
 
Join Date: May 2002
Location: Aalborg, Denmark
Quote:
Originally posted by analog_sa
[B]It's been years since i last had anything to do with electrostats and my advice may be quite rusty. It's unlikely anything is shorted. Can you check that your high voltage is ok?
- No, I'm afraid I cannot - I don't have a voltmeter that will take 5000 volts - is ther any other way to check the high voltage than to measure it directley ?
Quote:
And all the panels are getting it?
- What reasons should I target for them not to get it - failed solderings ?
Quote:
If yes, the mylar is probably not holding the charge any more. I've successfully used colloid solution of carbon dust or various antistatic sprays.
- Ok, so what you suggest is to reapply some coating ?
Quote:
Opening the panels will allow you to inspect the mylar for pin-holes as well.
- Pinholes - would that be burned out holes because of arching ??
Quote:
good luck

peter
I think I'll need it

Thank you so much for you effort !

/Hans
  Reply With Quote
Old 23rd January 2003, 05:31 PM   #4
diyAudio Member
 
RobWells's Avatar
 
Join Date: Aug 2002
Location: UK
Hello

These people advertise in hi-fi news (uk mag).
I don't know if they're good or bad, but they say they sell panels for quad 57.

They're based in Germany

e-mail:

quad.ger@t-online.de

Good luck!

Rob
  Reply With Quote
Old 23rd January 2003, 08:31 PM   #5
diyAudio Member
 
Join Date: Sep 2001
Hans, I know they no longer support the '57 and transferred the jigs to the German company mentioned but I would be surprised if Quad were no longer supporting the ESL63. Have you tried contacting them yet?
Their latest models are still basically ESL63's but with extra base sections, so I would have thought they can still service the '63.

Andrew
  Reply With Quote
Old 23rd January 2003, 09:47 PM   #6
diyAudio Member
 
MRehorst's Avatar
 
Join Date: May 2002
If there isn't any visible problem with the speaker (torn diaphragm, for example), put a brush attachment on your vacuum cleaner and try vacuuming the panels clean, especially around the edge of the drivers. The stators don't go all the way to the edges, but something like a cat hair between the diaphragm and stator can cause a problem.

There are four panels inside the speaker. If one has stopped working you will be able to tell by listening with your ear close to the speaker. Start at the top edge of the speaker and slowly move your head down. A dead panel will become obvious.

Another potential problem is that the HV supply is not producing adequate voltage. First, check the line voltage input switches on both speakers and make sure both are set to the same and correct voltage. If a rectifier in the voltage multiplier dies, I believe you will see lower voltage at the output. This is an easy and inexpensive problem to fix. Just get a bunch of 10kV rated diodes and replace them all. It won't cost more than a few dollars (or whatever currency you use) and about an hour of your time.

Once you fix them, put some dust covers on them. They were there for a reason (as you may be finding out the hard way).

MR
__________________
Keeping an open mind since 2002...
  Reply With Quote
Old 23rd January 2003, 09:48 PM   #7
diyAudio Member
 
Join Date: Sep 2001
Location: Northern California
Contact Dr. Sheldon Stokes at SDS Labs over in New Mexico. Sheldon knows his way around the Quad's insides.

Cyclotronguy
  Reply With Quote
Old 23rd January 2003, 11:23 PM   #8
Buhl is offline Buhl  Denmark
diyAudio Member
 
Buhl's Avatar
 
Join Date: May 2002
Location: Aalborg, Denmark
Default Parts for the Quad ESL 63

Hi Guys
Thanx for all the replies - I understand now that the problem migth not be caused by shortend panels, but the electronics may also have a role to play. I will devote some time to have them checked according to the service manual, by a skilled technician, as im afraid to work with high voltage ( dont know if it is as dangerous as i think it is...)

I have made the proposed test with listening from "the top and down" with the ear close to the panels, and I do not think that any of the panels are "dead", but especially the two panels behind the circles are more dull, compared to the other speaker.
I think the problem migth be the voltage supply, or as one have suggested - mechanical weak solderings, causing some of the ring shaped panels not to have higt voltage, and thus not playing.

If it turns out to be faulty panels, I have located a nice spare parts supplyer - located in Sweeden, wery close to where I live in Denmark - nice !
URL: http://user.tninet.se/~vhw129w/mt_au...sign/index.htm

Thanx again for the replys, I will start investigating


Cheers !

Hans Houmøller
  Reply With Quote
Old 9th February 2003, 06:41 PM   #9
diyAudio Member
 
Join Date: Apr 2002
Location: Toronto
Default Neon power supply light for ESL63

I have owned two sets of FREDs and have experienced the following problems on both sets.

Sound level drops dramtically on one speaker.
The cause in both cases were one or more high voltage diodes in the power supply became conductive and so the total high voltage was reduced.

There is a small board which multiplies the DC voltage by a factor of about 6 times.
It does this in steps with a capacitor and diode for each step.
If a diode goes you lose a step and you lose very high voltage.

Remove the bottom metal plate via about 10 screws on both ESL63s.
Power the FREDS up without any amplifier connected.
There is a little neon bulb on a little daughter board which can be seen if you look up from underneath.

If the power supply is functioning properly the neon bulb will blink every second or so. If the bulb does not go off you have blown a diode or diodes. The bulbs of both speakers should blink at the same rate.

The high voltage diodes are very cheap. $5.00 will get you enough for both speakers.
The board on which they sit can easily be removed by disconnecting the two small wires from the high voltage transformer and the very high voltage wire to the output to the mylar panels. Two small Phillips head bolts hold the board to the frame. The diodes are potted in wax which can easily be melted away and then replaced.
Good luck
  Reply With Quote
Old 9th February 2003, 06:48 PM   #10
diyAudio Member
 
Join Date: Apr 2002
Location: Toronto
Default ESL high voltage

The panels generate about 6,000 volts DC however the current is minimal. A television set is way way more leathal.

I have inadvertantly touched the high voltage leads and it is not a pleasant feeling but O.K. It is like getting a shock from shuffling your feet across a rug and then touching something conductive.

If you are going to work on your speakers unplug them for a day to let the capacitors discharge. They are really very safe and very well made.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS- Quad ESL-63 frame parts I_Forgot Swap Meet 4 13th June 2010 10:58 AM
Quad 34 - parts clarification johnm Solid State 23 16th March 2010 04:35 PM
WTB: RGR Model IV parts or parts unit dnewma04 Swap Meet 2 1st January 2010 09:00 PM
PARTS PARTS PARTS!!! Infocus Powerview 820, triplet, ballast, light, power supply!!! marioinla Swap Meet 1 31st August 2004 04:22 PM


New To Site? Need Help?

All times are GMT. The time now is 08:38 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2