Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PC Based Computer music servers, crossovers, and equalization

Ultimate MPD (SACD ISO, Native DSD, and more)
Ultimate MPD (SACD ISO, Native DSD, and more)
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 17th August 2016, 08:52 PM   #11
altblitz is offline altblitz
diyAudio Member
Join Date: Dec 2013
$ pacaur -Ql | grep glib.h
reveals /usr/include/glib-2.0/glib.h in glib2 library
  Reply With Quote
Old 19th August 2016, 06:56 AM   #12
tuxx is offline tuxx  Greece
diyAudio Member
Join Date: May 2014
Location: Greece
I had the same problem compiling the sacd fork and I resolved it with the following code:

# Quick fix for missing glib-2.0 include.
sed -i 's/DSD_CFLAGS = \\/DSD_CFLAGS = $(MMS_CFLAGS) \\/' "${srcdir}"/mpd/Makefile
You can see the code here inside my PKGBUILD:


The fix is not mine. I got it from an AUR PKGBUILD:

  Reply With Quote
Old 21st August 2016, 02:39 PM   #13
xxxbugxxxx is offline xxxbugxxxx
diyAudio Member
Join Date: Jul 2011
Use this for make command:

make install CPPFLAGS="$(pkg-config --cflags glib-2.0)"

Sent from my iPhone using Tapatalk
  Reply With Quote
Old 13th September 2016, 10:02 PM   #14
Mistic0 is offline Mistic0  Spain
diyAudio Member
Join Date: Jan 2013
Originally Posted by xxxbugxxxx View Post
Use this for make command:

make install CPPFLAGS="$(pkg-config --cflags glib-2.0)"

Sent from my iPhone using Tapatalk
I tried two command that you proposed, but error continues..
Another intent, another command...(from a good friend)

CPPFLAGS=$(pkg-config --cflags glib-2.0) ./configure --enable-sacdiso --disable-iso9660
but...glib. h error continues present..

Congralutations for your script, and share us...
Please, could you help me?

Thank's a lot in advance
  Reply With Quote
Old 23rd October 2016, 09:53 PM   #15
vuki is offline vuki  Croatia
diyAudio Member
vuki's Avatar
Join Date: Jun 2002
Location: zagreb, croatia
The above helped with glib.h but I'm getting this error now:

|| echo './'`src/lib/sacdiso/sacd_metabase.cpp
src/lib/sacdiso/sacd_metabase.cpp:23:25: fatal error: openssl/md5.h: No such file or directory
#include <openssl/md5.h>
compilation terminated.
Makefile:8449: recipe for target 'src/lib/sacdiso/libdecoder_a-sacd_metabase.o' failed
make[1]: *** [src/lib/sacdiso/libdecoder_a-sacd_metabase.o] Error 1
make[1]: Leaving directory '/home/volumio/MPD'
Makefile:15617: recipe for target 'install' failed
make: *** [install] Error 2
please help
  Reply With Quote
Old 23rd October 2016, 10:39 PM   #16
xxxbugxxxx is offline xxxbugxxxx
diyAudio Member
Join Date: Jul 2011
Check the log , it should be related to missing xml parser

Sent from my iPhone using Tapatalk
  Reply With Quote
Old 23rd October 2016, 11:09 PM   #17
xxxbugxxxx is offline xxxbugxxxx
diyAudio Member
Join Date: Jul 2011
Try " apt-get install libexpat1-dev"

That error is basically missing libexpat..
./configure log should point to it too

Last edited by xxxbugxxxx; 23rd October 2016 at 11:15 PM.
  Reply With Quote
Old 24th October 2016, 05:18 AM   #18
vuki is offline vuki  Croatia
diyAudio Member
vuki's Avatar
Join Date: Jun 2002
Location: zagreb, croatia
Still the same error

$ ./configure --enable-sacdiso --disable-iso9660

## --------- ##
## Platform. ##
## --------- ##

hostname = volumio
uname -m = armv6l
uname -r = 4.4.9+
uname -s = Linux
uname -v = #884 Fri May 6 17:25:37 BST 2016

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = unknown
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/bin
PATH: /usr/bin
PATH: /bin
PATH: /usr/local/games
PATH: /usr/games

## ----------- ##
## Core tests. ##
## ----------- ##

configure:3004: checking for a BSD-compatible install
configure:3072: result: /usr/bin/install -c
configure:3083: checking whether build environment is sane
configure:3138: result: yes
configure:3289: checking for a thread-safe mkdir -p
configure:3328: result: /bin/mkdir -p
configure:3335: checking for gawk
configure:3365: result: no
configure:3335: checking for mawk
configure:3351: found /usr/bin/mawk
configure:3362: result: mawk
configure:3373: checking whether make sets $(MAKE)
configure:3395: result: yes
configure:3424: checking whether make supports nested variables
configure:3441: result: yes
  Reply With Quote
Old 24th October 2016, 05:26 AM   #19
xxxbugxxxx is offline xxxbugxxxx
diyAudio Member
Join Date: Jul 2011
can you try ./autogen ./configure etc again? It is just some lib missing, you should be able to read through the ./configure prompts to find it which one. The error you mentioned, I faced the same first time and fixed by adding in expat

Sent from my iPhone using Tapatalk
  Reply With Quote
Old 24th October 2016, 07:30 AM   #20
vuki is offline vuki  Croatia
diyAudio Member
vuki's Avatar
Join Date: Jun 2002
Location: zagreb, croatia
checking for boostlib >= 1.46... yes
checking for ICU... yes
configure: auto-detected libicu
checking for ipv6... yes
checking for struct ucred... yes
checking for getpeereid... no
checking for SYSTEMD_DAEMON... no
checking for SYSTEMD_DAEMON... no
configure: WARNING: libsystemd not found -- disabling systemd socket activation
checking for LIBMPDCLIENT... no
configure: WARNING: libmpdclient not found -- disabling MPD client library
checking for EXPAT... yes
configure: auto-detected expat XML parser
checking for inotify_init... yes
checking for inotify_init1... yes
checking tcpd.h usability... no
checking tcpd.h presence... no
checking for tcpd.h... no
configure: WARNING: libwrap not found -- disabling libwrap
checking for ID3TAG... no
checking for id3_file_open in -lid3tag... no
configure: WARNING: libid3tag not found -- disabling ID3 support using libid3tag
checking for AVAHI... yes
configure: auto-detected avahi client library
checking for SQLITE... no
configure: WARNING: sqlite not found -- disabling SQLite database support
checking for LIBSAMPLERATE... no
configure: WARNING: libsamplerate not found -- disabling libsamplerate resampling
checking for SOXR... no
configure: WARNING: libsoxr not found -- disabling libsoxr resampler
checking for CURL... no
configure: WARNING: libcurl not found -- disabling libcurl HTTP streaming
checking for SMBCLIENT... no
checking for smbc_init in -lsmbclient... no
configure: WARNING: libsmbclient not found -- disabling smbclient input plugin
checking for NFS... no
configure: WARNING: libnfs not found -- disabling NFS input plugin
checking for YAJL... no
configure: WARNING: libyajl not found -- disabling soundcloud.com support
checking for CDIO_PARANOIA... no
configure: WARNING: libcdio_paranoia not found -- disabling libcdio_paranoia input plugin
checking for MMS... no
configure: WARNING: libmms not found -- disabling libmms mms:// protocol support
checking for ZLIB... yes
configure: auto-detected zlib support
checking for BZ2_bzDecompressInit in -lbz2... no
configure: WARNING: libbz2 not found -- disabling bzip2 archive plugin
checking for UPNP... no
configure: WARNING: libupnp not found -- disabling UPnP client support
checking for ADPLUG... no
configure: WARNING: libadplug not found -- disabling AdPlug decoder plugin
checking for AUDIOFILE... no
configure: WARNING: libaudiofile not found -- disabling audiofile decoder plugin
checking for NeAACDecOpen in -lfaad... no
configure: WARNING: libfaad not found -- disabling FAAD decoder plugin
checking for FFMPEG... no
configure: WARNING: libavformat+libavcodec+libavutil not found -- disabling ffmpeg decoder library
checking for FLAC... no
configure: WARNING: libFLAC not found -- disabling FLAC decoder
checking for FLUIDSYNTH... no
configure: WARNING: fluidsynth not found -- disabling fluidsynth MIDI decoder plugin
checking for GME... no
checking for gme_open_file in -lgme... no
configure: WARNING: libgme not found -- disabling Game Music Emulator decoder plugin
checking for MAD... no
checking for mad_stream_init in -lmad... no
configure: WARNING: libmad not found -- disabling libmad MP3 decoder plugin
checking for SHOUT... no
configure: WARNING: libshout not found -- disabling shout output plugin
checking for MPG123... no
configure: WARNING: libmpg123 not found -- disabling libmpg123 decoder plugin
checking for MODPLUG... no
configure: WARNING: libmodplug not found -- disabling modplug decoder plugin
checking for OPUS... no
configure: WARNING: libopus not found -- disabling opus decoder plugin
checking for SNDFILE... no
configure: WARNING: libsndfile not found -- disabling libsndfile decoder plugin
checking for mpc_demux_init in -lmpcdec... no
configure: WARNING: libmpcdec not found -- disabling Musepack decoder plugin
checking for VORBIS... no
configure: WARNING: libvorbis not found -- disabling Ogg Vorbis decoder
checking for SIDPLAY... no
checking for SIDPLAY... no
configure: WARNING: libsidplay2 not found -- disabling sidplay decoder plugin
checking for WAVPACK... no
configure: WARNING: libwavpack not found -- disabling WavPack decoder plugin
checking for WildMidi_Init in -lWildMidi... no
configure: WARNING: libwildmidi not found -- disabling WildMidi decoder plugin
checking for SHINE... no
configure: WARNING: libshine not found -- disabling shine encoder
checking for VORBISENC... no
configure: WARNING: libvorbisenc not found -- disabling Ogg Vorbis encoder
checking for lame_init in -lmp3lame... no
configure: WARNING: libmp3lame not found -- disabling LAME encoder plugin
checking for TWOLAME... no
configure: WARNING: libtwolame not found -- disabling TwoLAME encoder plugin
checking for ALSA... no
configure: WARNING: libasound not found -- disabling ALSA output plugin
checking for ROAR... no
configure: WARNING: libroar not found -- disabling RoarAudio output plugin
checking for mkfifo... yes
checking sndio.h usability... no
checking sndio.h presence... no
checking for sndio.h... no
configure: WARNING: sndio.h not found -- disabling support for sndio output
checking media/MediaDefs.h usability... no
checking media/MediaDefs.h presence... no
checking for media/MediaDefs.h... no
checking for JACK... no
configure: WARNING: libjack not found -- disabling JACK output plugin
checking for AO... no
configure: WARNING: libao not found -- disabling libao output plugin
checking for OPENAL... no
configure: WARNING: OpenAL not found -- disabling OpenAL output plugin
checking sys/soundcard.h usability... yes
checking sys/soundcard.h presence... yes
checking for sys/soundcard.h... yes
checking for PULSE... no
  Reply With Quote


Ultimate MPD (SACD ISO, Native DSD, and more)Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Something cool for Raspberry Pi/ODROID: I2S/DSD isolator HAT with native DSD decoder iancanada PC Based 331 18th March 2018 07:24 PM
AudioMate, a Desktop Tool for SACD-ISO & DSD simonvan PC Based 1 25th July 2014 11:09 AM
DSD (SACD) FIR based software crossover emaster PC Based 21 15th April 2014 05:47 PM
How To Rip a SACD to DSD file Eddiegnz1 PC Based 3 28th March 2014 06:24 AM
SACD's DSD signal rerouting sp502 Digital Source 9 12th September 2008 07:53 AM

New To Site? Need Help?

All times are GMT. The time now is 11:07 PM.

Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio