Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PC Based Computer music servers, crossovers, and equalization

Moode Audio Player for Raspberry Pi
Moode Audio Player for Raspberry Pi
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th February 2018, 11:38 PM   #13561
skypoke is offline skypoke  United States
diyAudio Member
 
Join Date: Oct 2004
Another happy camper here, built the image and installed without a hitch using Heebo's and Drone's instructions, and Tim's great code. The UI through a wireless keyboard and mouse and 42" TV is very nice as well. I note a graphic equalizer in there as well, but have been unable to invoke it. Can anyone offer tips as to what I am overlooking? No on button, just off. I'm assuming it's tied to other functions which must be enabled?

TIA, Chuck
  Reply With Quote
Old 10th February 2018, 12:34 AM   #13562
TimCurtis is online now TimCurtis  United States
diyAudio Member
 
TimCurtis's Avatar
 
Join Date: Jan 2012
Location: Metro-Detroit
Hi @skypoke,

Post moode log and the brief form of the build log.

cat /var/log/moode.log
mosbrief

-Tim
__________________
Enjoy the Music!
http://moodeaudio.org, http://twitter.com/MoodeAudio
  Reply With Quote
Old 10th February 2018, 12:39 AM   #13563
metalrob is offline metalrob
diyAudio Member
 
Join Date: Mar 2015
Hi guys!


I'm on 4.0 now;-). The new 2.3 recipe was all I needed.

But there are some issues for me (and maybe for others) to be solved:

1) What is the sense behind the Tidal-integration? I can't access it via the GUI. It only can be run via an app like BubbleUpnp...and that was usual practice for me till 3.8.4 anyway. The only difference now is, that I have a moode upnp-mediaserver in Bubble...but for what? Tidal is also to be started via the cloud on Bubble...and this does better, cause when choosing the moode-mediaserver I only get a max of 999 albums to choose out of my favorites...not enough If I have favorized about 2300.

2) The nice 'time-circle' isn't visualized with Note 8 using the Samsung browser. Would it show again when utilizing chrome as browser or is this feature generally gone with mobile-phone-usage?

3) What is the image builder for? I didn't need it for setting up moode 4.0. Are there any benefits using it?

4) I tried to make an image of new 4.0 installation using win32diskimager (1.0 version). Unfortunately after reading the sd card and burning the image to another one, booting didn't happen. Moreover I got two files after the reading process. The image file and something called fat 0 or similar. Is there an easy approach to realize a bootable image?

5) APMode doesn't seem to work in networks.


Thanx a lot for inputs:-)

Greetingz, Robert
  Reply With Quote
Old 10th February 2018, 01:06 AM   #13564
TimCurtis is online now TimCurtis  United States
diyAudio Member
 
TimCurtis's Avatar
 
Join Date: Jan 2012
Location: Metro-Detroit
Quote:
Originally Posted by metalrob View Post
Hi guys!


I'm on 4.0 now;-). The new 2.3 recipe was all I needed.

But there are some issues for me (and maybe for others) to be solved:

1) What is the sense behind the Tidal-integration? I can't access it via the GUI. It only can be run via an app like BubbleUpnp...and that was usual practice for me till 3.8.4 anyway. The only difference now is, that I have a moode upnp-mediaserver in Bubble...but for what? Tidal is also to be started via the cloud on Bubble...and this does better, cause when choosing the moode-mediaserver I only get a max of 999 albums to choose out of my favorites...not enough If I have favorized about 2300.

2) The nice 'time-circle' isn't visualized with Note 8 using the Samsung browser. Would it show again when utilizing chrome as browser or is this feature generally gone with mobile-phone-usage?

3) What is the image builder for? I didn't need it for setting up moode 4.0. Are there any benefits using it?

4) I tried to make an image of new 4.0 installation using win32diskimager (1.0 version). Unfortunately after reading the sd card and burning the image to another one, booting didn't happen. Moreover I got two files after the reading process. The image file and something called fat 0 or similar. Is there an easy approach to realize a bootable image?

5) APMode doesn't seem to work in networks.


Thanx a lot for inputs:-)

Greetingz, Robert
Hi Rob,

Make a build using the Automated Builder. It ensures the integrity of the image. Then see if you experience issues #2 and #5.

I use DD on the Mac and Linux for reading/writing images and no issues. I don't have any experience with the image util u are using but other users have reported success with latest versions of Etcher and Win32DiskImager.

-Tim
__________________
Enjoy the Music!
http://moodeaudio.org, http://twitter.com/MoodeAudio
  Reply With Quote
Old 10th February 2018, 01:16 AM   #13565
swizzle is offline swizzle  United States
diyAudio Member
 
Join Date: Apr 2017
Quote:
Originally Posted by metalrob View Post
Hi guys!

1) What is the sense behind the Tidal-integration? I can't access it via the GUI. It only can be run via an app like BubbleUpnp...and that was usual practice for me till 3.8.4 anyway.
It runs natively on the Pi instead of being cast from your device to the Pi. Most people think this improves the sound quality.

Quote:
2) The nice 'time-circle' isn't visualized with Note 8 using the Samsung browser. Would it show again when utilizing chrome as browser or is this feature generally gone with mobile-phone-usage?
It should show in landscape mode, all small screen devices will likely get a slightly revised version that fits more easily onto small screens with 4.1 without using the css zoom which can cause problems.
  Reply With Quote
Old 10th February 2018, 04:41 AM   #13566
BryceJ is offline BryceJ  Canada
diyAudio Member
 
Join Date: Jul 2013
Location: Vancouver, BC
Quote:
Originally Posted by metalrob View Post
4) I tried to make an image of new 4.0 installation using win32diskimager (1.0 version). Unfortunately after reading the sd card and burning the image to another one, booting didn't happen. Moreover I got two files after the reading process. The image file and something called fat 0 or similar. Is there an easy approach to realize a bootable image?
Hi Robert, I have used the following steps to make an image of my moOde 4.0 installation with win32DiskImager.

I make the image file after the build is complete and I have made a few simple modifications such as setting the correct timezone, or picking a default color.
  1. Start Win32DiskImager
  2. In "Image File" enter the path and filename you want for your image file. For example: C:\Users\Robert\moOde images\moode40.img
  3. Use the "Device" dropdown list to select your SD card
  4. Check "Read Only Allocated Partitions" checkbox
  5. Click the "Read" button to create the image file from your SD card.

This should create the image file moode40.img, just over 3GB in size, on your computer.

Once Win32DiskImager completes you can then use the image file to create other SD cards

I hope that helps.
  Reply With Quote
Old 10th February 2018, 05:01 AM   #13567
TimCurtis is online now TimCurtis  United States
diyAudio Member
 
TimCurtis's Avatar
 
Join Date: Jan 2012
Location: Metro-Detroit
Hi,

Just a heads up that I've turned off the internal "install latest kernel" option in the official Image Builder at moodeaudio.org due to Raspbian Team bump to the new 4.14.y kernel branch and a requirement for yN confirmation to install the new kernel that can't be scripted to Y.

pi@rp3:~ $ sudo PRUNE_MODULES=1 rpi-update
*** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
*** Performing self-update
*** Relaunching after update
*** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
################################################## ###########
WARNING: This update bumps to rpi-4.14.y linux tree
Be aware there could be compatibility issues with some drivers
Discussion here:
Moving Linux kernel to 4.14 - Raspberry Pi Forums
################################################## ############
Would you like to proceed? (y/N)
pi@rp3:~ $


TBD whether this branch update causes breakage :-0

-Tim
__________________
Enjoy the Music!
http://moodeaudio.org, http://twitter.com/MoodeAudio
  Reply With Quote
Old 10th February 2018, 07:38 AM   #13568
metalrob is offline metalrob
diyAudio Member
 
Join Date: Mar 2015
@Tim, Swizzle and BryceJ

Thanx for your helpful comments!

Greetingz, Robert
  Reply With Quote
Old 10th February 2018, 08:15 AM   #13569
philrandal is offline philrandal  United Kingdom
diyAudio Member
 
Join Date: Jan 2016
Location: Hereford, UK
Quote:
Originally Posted by TimCurtis View Post
Hi,

Just a heads up that I've turned off the internal "install latest kernel" option in the official Image Builder at moodeaudio.org due to Raspbian Team bump to the new 4.14.y kernel branch and a requirement for yN confirmation to install the new kernel that can't be scripted to Y.

pi@rp3:~ $ sudo PRUNE_MODULES=1 rpi-update
*** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
*** Performing self-update
*** Relaunching after update
*** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
################################################## ###########
WARNING: This update bumps to rpi-4.14.y linux tree
Be aware there could be compatibility issues with some drivers
Discussion here:
Moving Linux kernel to 4.14 - Raspberry Pi Forums
################################################## ############
Would you like to proceed? (y/N)
pi@rp3:~ $


TBD whether this branch update causes breakage :-0

-Tim
Yes, it broke my Moode player's ability to mount (using CIFS) a disk drive shared from my TP-Link router.

Still checking out possible mount options to fix it.

Sorted! Needed to add

Code:
vers=1.0,sec=ntlm
to the end of the mount string.

Phil
__________________
Pi Zero W + Pimoroni pHAT DAC / Pro-ject Elemental / Marantz CD6004 / Marantz PM6004 / Monitor Audio Bronze 2

Last edited by philrandal; 10th February 2018 at 08:43 AM.
  Reply With Quote
Old 10th February 2018, 08:18 AM   #13570
JonPike is offline JonPike  United States
diyAudio Member
 
Join Date: Feb 2004
Location: Irvine
Have finally upgraded my main RPi (Pi 3b) to 4.0. Only broke the process once, due to seriously dumb mistake, aka switching off lights for the evening that had the Pi power supply on same power strip. Doh!

Everything looks and runs great, with a few issues. I'm liking an apparent improvement of response over all, seems snappier now. I also had some crackle and pops in my set up, started w 3.84 and didn't quite go away in 4.0 b12, seems very solid now.

So, on to the few issues...

1. I occasionally lose some display features, the time ring will not be there, or sometimes the entire playlist isn't visible in playlist page. Also, lately have been seeing most or all of these appearing properly, but no pic for the radio station playing. My playlist load so far has only consisted of radio stations. I've fiddled with various things, reloading, going to other pages and returning... sometime it comes back, sometimes not. Not sure of a single fix yet.

2. More a feature change opinion than a problem, I'm finding the volume control a bit of an issue in that I miss the bump up/down buttons, which were handy for fine adjustments without accidental large motions. And I like the new slider bar, but I don't like the "no change till you let go and drop it" feature. Very difficult to judge how much change you made, especially on a small phone screen. Is the "drag around the circular volume indicator" no longer available? That used to be a smooth transition, with the occasional user issue of hitting the wrong side and blasting a high volume.

Most of the things in 1 have been seen on Firefox on my Android phone, otherwise I'm on Firefox on Win 10. I have seen 1 problems on the phone, and seen normal operation on the Win 10 browser.

Hope that helps...
  Reply With Quote

Reply


Moode Audio Player for Raspberry PiHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My DAC for the Raspberry Pi usul27 Digital Line Level 156 30th April 2017 12:10 AM
DSP for the Raspberry Pi usul27 Digital Line Level 39 30th August 2016 08:29 AM
Raspberry Pi + CirrusLogic Audio Card = FAIL solderhead PC Based 31 26th January 2016 07:48 PM
RaspyFi/Volumio - Turn raspberry Pi into Audiophile audio Player mikelangeloz PC Based 295 14th June 2014 06:32 PM
miniAMP and raspberry pi kp93300 miniDSP 0 3rd March 2014 04:38 AM


New To Site? Need Help?

All times are GMT. The time now is 06:30 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki