Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PC Based Computer music servers, crossovers, and equalization

Archphile - An Archlinux Based Audiophile Distribution for Raspberry Pi and Udoo Quad
Archphile - An Archlinux Based Audiophile Distribution for Raspberry Pi and Udoo Quad
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th May 2018, 11:13 AM   #221
pinkdot is offline pinkdot  Netherlands
diyAudio Member
 
Join Date: Nov 2016
Location: Zutphen
Quote:
Originally Posted by tuxx View Post
@pinkdot, please can you double-check with htop to see if you have any running librespot processes?
Hi tuxx,

No, Htop won't show the service. Librespot does run if I start it manually. But after a restart it fails. I changed the service and added the StartLimitInterval=30 and StartLimitBurst=20. This seems to do the job. After a restart Librespot starts!

Code:
[Service]
EnvironmentFile=/etc/librespot.conf
ExecStart=/usr/bin/librespot \
  --cache ${LIBRESPOT_CACHE} \
  --name %H \
  --device plughw:0 \
  --bitrate ${LIBRESPOT_BITRATE} \
  --username ${LIBRESPOT_USERNAME} \
  --password ${LIBRESPOT_PASSWORD} \
  --initial-volume 85
Restart=always
RestartSec=10
StartLimitInterval=30
StartLimitBurst=20
User=librespot
Group=audio
  Reply With Quote
Old 16th May 2018, 11:19 AM   #222
tuxx is offline tuxx  Greece
diyAudio Member
 
tuxx's Avatar
 
Join Date: May 2014
Location: Greece
The direct link above is wrong. The manual can be found here:


http://archphile.org/manual/archphile-manual.pdf

@Rucia1, at this stage I only support Spotify. I don't use tidal and I can't help in troubleshooting.
__________________
My Blog!
Read the F*#!ing Manual!
  Reply With Quote
Old 16th May 2018, 11:32 AM   #223
Rucia1 is offline Rucia1
diyAudio Member
 
Join Date: Sep 2017
I go back to moodeaudio
  Reply With Quote
Old 16th May 2018, 11:41 AM   #224
tuxx is offline tuxx  Greece
diyAudio Member
 
tuxx's Avatar
 
Join Date: May 2014
Location: Greece
Quote:
Originally Posted by pinkdot View Post
Hi tuxx,

No, Htop won't show the service. Librespot does run if I start it manually. But after a restart it fails. I changed the service and added the StartLimitInterval=30 and StartLimitBurst=20. This seems to do the job. After a restart Librespot starts!

Code:
[Service]
EnvironmentFile=/etc/librespot.conf
ExecStart=/usr/bin/librespot \
  --cache ${LIBRESPOT_CACHE} \
  --name %H \
  --device plughw:0 \
  --bitrate ${LIBRESPOT_BITRATE} \
  --username ${LIBRESPOT_USERNAME} \
  --password ${LIBRESPOT_PASSWORD} \
  --initial-volume 85
Restart=always
RestartSec=10
StartLimitInterval=30
StartLimitBurst=20
User=librespot
Group=audio



Thanks for the feedback pinkdot. It's really strange because I have been using Spotify in both RPI and Odroid C2 without any issues.



I will do my search and maybe I will add these options by default.


Looking at your file, I assume that you don't use the latest image, right?


M.
__________________
My Blog!
Read the F*#!ing Manual!

Last edited by tuxx; 16th May 2018 at 11:44 AM.
  Reply With Quote
Old 16th May 2018, 11:50 AM   #225
Dimdim is offline Dimdim  Greece
diyAudio Member
 
Join Date: Sep 2008
Location: Athens
Archphile - An Archlinux Based Audiophile Distribution for Raspberry Pi and Udoo Quad
Quote:
Originally Posted by tuxx View Post
The direct link above is wrong. The manual can be found here:


http://archphile.org/manual/archphile-manual.pdf
This is one hard-core manual! More like a textbook for MPD on Archlinux.

Well done!
__________________
http://www.dimdim.gr
  Reply With Quote
Old 16th May 2018, 04:47 PM   #226
pinkdot is offline pinkdot  Netherlands
diyAudio Member
 
Join Date: Nov 2016
Location: Zutphen
Quote:
Originally Posted by tuxx View Post
Looking at your file, I assume that you don't use the latest image, right?


M.
I do, but let me reflash the image on another sd card and try again. I'll report back .
  Reply With Quote
Old 17th May 2018, 05:28 AM   #227
pinkdot is offline pinkdot  Netherlands
diyAudio Member
 
Join Date: Nov 2016
Location: Zutphen
Quote:
Originally Posted by pinkdot View Post
I do, but let me reflash the image on another sd card and try again. I'll report back .
Still the same, flashed a new image but I have to add the extra lines to the service to get Librespot running after a reboot.

Is there a simple way to make alsactl store persistent? After a reboot all settings are restored to 100%? I know that this is as intended, but the output is way to high for my amp. To reduce the alsa output allows me to set a more accurate amp volume.
Alsactl restore works but not during startup. So I have to rum the command manually. Any hints?
  Reply With Quote
Old 17th May 2018, 06:24 AM   #228
tuxx is offline tuxx  Greece
diyAudio Member
 
tuxx's Avatar
 
Join Date: May 2014
Location: Greece
Εverything is restored to 100% (0dB), because I have set it up to do this in order to achieve a bit perfect result.


During all these years only some I2S dacs (and that was fixed) weren't 0db at 100%.


You have two options:


1. edit /usr/bin/archphile-optimize and disable the unmute command


2. edit /usr/bin/unmute and modify it as per your preferences!
__________________
My Blog!
Read the F*#!ing Manual!
  Reply With Quote
Old 17th May 2018, 09:38 AM   #229
flexus is offline flexus  Austria
diyAudio Member
 
Join Date: May 2007
@pinkdot: is this a systemd unit file? why is there no startup dependency like multi-user.target ?
@ tuxx: nice writeup, i've already seen some stuff i'd like to check out these days
  Reply With Quote
Old 17th May 2018, 11:18 AM   #230
pinkdot is offline pinkdot  Netherlands
diyAudio Member
 
Join Date: Nov 2016
Location: Zutphen
Quote:
Originally Posted by flexus View Post
@pinkdot: is this a systemd unit file? why is there no startup dependency like multi-user.target ?
@ tuxx: nice writeup, i've already seen some stuff i'd like to check out these days
Yes there is. See full current service on github: playground/librespot.service at master * archphile/playground * GitHub
  Reply With Quote

Reply


Archphile - An Archlinux Based Audiophile Distribution for Raspberry Pi and Udoo QuadHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My DAC for the Raspberry Pi usul27 Digital Line Level 156 29th April 2017 11:10 PM
DSP for the Raspberry Pi usul27 Digital Line Level 39 30th August 2016 07:29 AM
To Raspberry Pi/BeagleBone Black/CuBox/UDOO owners: RuneAudio is looking for testers ACX PC Based 173 10th November 2015 06:44 PM
RaspyFi/Volumio - Turn raspberry Pi into Audiophile audio Player mikelangeloz PC Based 295 14th June 2014 05:32 PM
miniAMP and raspberry pi kp93300 miniDSP 0 3rd March 2014 03:38 AM


New To Site? Need Help?

All times are GMT. The time now is 12:44 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki