Can anybody spot what setting I need to change? - diyAudio
Go Back   Home > Forums > Source & Line > PC Based

PC Based Computer music servers, crossovers, and equalization

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th March 2014, 10:37 PM   #1
vhopper is offline vhopper  United Kingdom
diyAudio Member
 
Join Date: Mar 2014
Default Can anybody spot what setting I need to change?

Does anybody possibly know the answer to my problem?

My set up is windows 8.1, an Asus sound card connected to a receiver via S/PDIF. I have a set of 5.1 speakers connected to the receiver. Everything works as it should when playing games, movies, you tube etc. I get 5.1 sound. There is one program that will only give me stereo sound. Below is the screenshot of my options for the sound.


Click the image to open in full size.

I have a few choices for audio output device and passthrough output device but the only ones that will give me any sound are

Directsound: spdif - s/pdif pass through device (asus xonar d2x audio device)

and

Wasapi : spdif - s/pdif pass-through device (asus xonar d2x audio device)

Can anybody see from those settings why I am not getting 5.1 sound?

Via coaxial/optical out put the digital formats supported by the receiver are

Dolby Digital 5.1

DTS 5.1

DTS 96/24 5.1

My receiver is a Sony STR-DH540
  Reply With Quote
Old 12th March 2014, 11:31 PM   #2
vhopper is offline vhopper  United Kingdom
diyAudio Member
 
Join Date: Mar 2014
If it helps the program is called XBMC
  Reply With Quote
Old 13th March 2014, 12:04 AM   #3
diyAudio Member
 
Join Date: Nov 2004
Location: Germany
Could it be that the wrong audio track is played back (DVDs usually come with multiple ones, and you can typically select the one to be played in software)? Or that a downmix is performed? You may also have to set up the Asus driver (a current one, I hope?) to use SPDIF only.

BTW, you shouldn't be getting 5.1 audio on Youtube, at least it doesn't provide any - only upmixing would do this.
  Reply With Quote
Old 13th March 2014, 01:46 AM   #4
flexus is offline flexus  Austria
diyAudio Member
 
Join Date: May 2007
is another surround source available with spdif output like a dvd player?
- to be sure about the settings on your receiver.

otherwise the latest beta rev. of xbmc is "gotham", maybe you got it already. (dont think its the problem)
  Reply With Quote
Old 13th March 2014, 02:01 AM   #5
diyAudio Member
 
Join Date: Jun 2011
The settings look right to me. Are you playing a BluRay or DVD with surround on the computer? In other words, does the source have surround content? Is that content switched on in the movie title menu?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sweet spot rock12 Full Range 3 23rd January 2013 09:39 PM
change the voltage setting from 115 V to 220V Jempie Digital Source 4 21st May 2010 11:50 PM
The Sweet Spot Nelson Pass Pass Labs 54 12th November 2009 01:53 PM


New To Site? Need Help?

All times are GMT. The time now is 01:18 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2