Help with BruteFIR configuration - diyAudio
Go Back   Home > Forums > Source & Line > PC Based

PC Based Computer music servers, crossovers, and equalization

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th January 2013, 10:03 PM   #1
Crumboo is offline Crumboo  Sweden
diyAudio Member
 
Join Date: Dec 2007
Default Help with BruteFIR configuration

Hi,

I am having some problems building a PC-based crossover based on Brutefir and wish that someone could help me out.

I am using a Intel Atom mini ITX board and have installed Voyage MPD linux distribution and Brutefir on a USB-stick in accordance with this document: http://www.acourate.com/freedownload...ACK%20v1.6.pdf.

As soundcard I am using the USBStreamer USBStreamer | miniDSP from miniDSP. The card is based on a XMOS chip and works as a USB audio class 2.0 device, which should be supported by Voyage (with built-in drivers). The card has 10 channels I/O (8 ch I2S and 2 ch toslink).

When starting Brutefir I get the following error:

Code:
ALSA I/O: Could not set audio input parameters for "hw":
  Failed to set channel count to 10: Invalid argument.
Failed to init input device.
Failed to initialise digital audio interfaces.
So I guess I have to do something to get the sound card to work correctly. In Brutefir, the I/O section in the configuration file looks like this:

Code:
## INPUT ##
input "left_in", "right_in" {
device: "alsa" { device: "hw";};  };
sample: "S16_LE";
channels: 10/8,9;
};

## OUTPUT ##
output "left_out", "right_out" {
device: "alsa" { device: "hw";}; };
sample: "S16_LE";
channels: 10/8,9;
delay: 0,0;
};
Do I have to do any more configurations in order to get the sound card to work in Brutefir? I am completely new to Linux and quite lost here, so I really would appreciate some help with this configuration!

Best regards,

Mattias
  Reply With Quote
Old 18th January 2013, 10:53 PM   #2
diyAudio Member
 
Join Date: Dec 2010
Location: wigan
Hi Mattias..
I just had a quick look around the web and found this .. mabe it will be of some help..

http://www.acourate.com/freedownload...ACK%20v1.6.pdf
  Reply With Quote
Old 19th January 2013, 09:52 AM   #3
Crumboo is offline Crumboo  Sweden
diyAudio Member
 
Join Date: Dec 2007
Thanks, but that is the document I referred to above as a guide for installing VoyageMPD and Brutefir. But for the actual soundcard configuration in Brutefir I'm quiet lost. Maybe some configuration file is needed?
  Reply With Quote
Old 19th January 2013, 04:27 PM   #4
diyAudio Member
 
Join Date: Aug 2009
Hello crumbo,

do you have ane experience with Linux or brutefir?

Otherwise i would recommend to start with an eassier Distro (with xserver) you could return to voyage after you got brutefir running.

My suggestion is Ubuntu 10.04 a liveCD i created in 2011.

A simple 2 way crossover should nearly run out of the box (most times usb cards are"hw:1" or something like that.)

I dont know the usb streamer, so at first you must check if linux supports 10 in´s and 10 out´s .

You can get the cd here, try to install it on a usb stick it needs only 1.4 gb.

Netload Serious Filehosting - Netload

Password is: hifi, user is: hifi; if you install it keep both of them.



Regards
  Reply With Quote
Old 19th January 2013, 06:07 PM   #5
phofman is offline phofman  Czech Republic
diyAudio Member
 
Join Date: Apr 2005
Location: Pilsen
Quote:
Originally Posted by Crumboo View Post
Code:
ALSA I/O: Could not set audio input parameters for "hw":
  Failed to set channel count to 10: Invalid argument.
Failed to init input device.
Failed to initialise digital audio interfaces.
Your hw (i.e. hw:0,0) device does not have 10 channels. Take a look at aplay -l (you can put the listing here), or use the parameter --dump-hw-params of newer aplay versions git.alsa-project.org Git - alsa-utils.git/blob - aplay/aplay.1
  Reply With Quote
Old 21st January 2013, 05:09 PM   #6
Crumboo is offline Crumboo  Sweden
diyAudio Member
 
Join Date: Dec 2007
Hi and thank you for your answers. No, I don't have any experience with Linux or Brutefir I'm afraid... maybe it would be better to try another distro as skyunlimited suggested.

Anyways, here is what I get when typing aplay -l:

Code:
root@voyage:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
The listed devices is the card built in the motherboard and the USB card isn't listed here. When I unplug the USB card and plug it in again I get the following:

Code:
[82786.942036] usb 1-5: new high-speed USB device number 6 using ehci_hcd
[82787.071186] usb 1-5: New USB device found, idVendor=2752, idProduct=0016
[82787.086003] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[82787.101001] usb 1-5: Product: USBStreamer
[82787.115857] usb 1-5: Manufacturer: miniDSP
[82787.130677] usb 1-5: SerialNumber: 0000
[82788.059947] usbaudio: unit 51: unexpected type 0x09
[82788.074690] snd-usb-audio: probe of 1-5:1.0 failed with error -5
Any suggestions?
  Reply With Quote
Old 21st January 2013, 07:38 PM   #7
phofman is offline phofman  Czech Republic
diyAudio Member
 
Join Date: Apr 2005
Location: Pilsen
The dmesg output clearly shows the module (driver) snd-usb-audio failed for your dac. Google search for the error message usbaudio unit unexpected type 0x09 - Hledat Googlem reveals your usb device advertises some extended mixer features the existing driver has not implemented yet and fails.

Advanced Linux Sound System development

One of the suggestions is to use the original XMOS firmware. Perhaps that one did not implement any of the fancy features. Is that an option for your miniDSP? Apparently the firmware can be upgraded Forum | miniDSP . Perhaps using older firmware would help. You can always ask on minidsp forums, I assume they should have tested linux by now.
  Reply With Quote
Old 23rd January 2013, 01:23 PM   #8
Crumboo is offline Crumboo  Sweden
diyAudio Member
 
Join Date: Dec 2007
Thank you, I posted on the miniDSP forum and hope someone can help me there. I've heard that others have been able to run the USBStreamer on Linux before...
  Reply With Quote
Old 23rd January 2013, 01:33 PM   #9
phofman is offline phofman  Czech Republic
diyAudio Member
 
Join Date: Apr 2005
Location: Pilsen
Quote:
Originally Posted by Crumboo View Post
I've heard that others have been able to run the USBStreamer on Linux before...
That is why I talked about the upgrade/downgrade of USBStreamer firmware. It is possible the older firmware did not define the extended mixer features.
  Reply With Quote
Old 24th January 2013, 06:46 AM   #10
Crumboo is offline Crumboo  Sweden
diyAudio Member
 
Join Date: Dec 2007
I'm not sure that there any upgrades/downgrades of the firmware for USBStreamer. It seems to me that the link you posted was about another miniDSP product.

Are there possibly any settings/configurations in ALSA that can be set to ignore? I found something in this thread that may be of use, but I can't find the the file "customdefines.h" anywhere in my system...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brutefir or min dsp greasergirl PC Based 4 13th March 2013 05:29 PM
Audio filtering with brutefir soundcheck Digital Source 2 16th November 2007 11:31 AM
Multiamplification + GeeXbox + BruteFIR man_jose Everything Else 0 31st August 2005 01:31 PM
BruteFIR bass redirection troubles birkinshawc Digital Source 0 5th January 2005 11:37 PM
BruteFIR / Volume control MWP Digital Source 9 24th November 2003 01:39 AM


New To Site? Need Help?

All times are GMT. The time now is 03:28 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2