ATX power supply noise. - diyAudio
Go Back   Home > Forums > Source & Line > PC Based

PC Based Computer music servers, crossovers, and equalization

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th October 2009, 09:35 PM   #1
diyAudio Member
 
Join Date: Oct 2009
Location: Hamburg
Default ATX power supply noise.

If your looking for a low electrical noise power supply avoid the Seasonic S12II ATX power supply. I assume it is causing by ground loop issues. My computer's "earth" is full of RF noise in the MHz region that is when shorted with a cap a clear 50 Hz can be seen on a scope, I was wondering if anyone had some simple suggestions for getting rid of these RF spikes on the earth.

In the near future I will receive a cheap external DAC and optical cable which should resolve the issue. (Thanks to this site for the idea)

24-Bit-Audio-D/A-Wandler ADA 24 | ELV-Elektronik

24-Bit-Audio-D/A-Wandler ADA 24 39,95 EUR
Adapterkabel ODT/ODT (Toslink), 1,5 m 2,95 EUR

I bought a cheap oscilloscope (ebay duel channel 20 Mhz@60 Euros) to repair a pair of Quad 303's (didn't need it in the end) I decided to look at the noise from my PC's with reference to the Hifi's earth.

It seems a shame to go for an external DAC just to loose the ground loop issue, and I guess their are better or worse power supplies, any suggestions on Low ground loop noise power supplies. I have a lot of sound cards some reasonable, and it seems a shame to loose any use of any of the inputs.

PS my first post to this site
  Reply With Quote
Old 16th October 2009, 10:20 PM   #2
diyAudio Member
 
Join Date: Oct 2009
Location: Hamburg
I reorganized the mains and have now removed the majority of the ground loop problem, some times you can be just dumb. Its now what most people would call HiFi but not perfect. The computer still introduces some ground loop effects unlike the cheap CD player I have. I hope the DAC improves the issue, but now I am not convinced the problem is the power supply as the levels could easily be the computer. Loading the ATX power supply (and I don't have all needed to hand) is too much work when I have the DAC coming. I will try to remember to update you on the relative quality and if it is as good or better than a mid nineties Cd player.
  Reply With Quote
Old 16th October 2009, 10:32 PM   #3
diyAudio Member
 
Join Date: Jan 2002
Location: Tyrone Ga. U.S.A.
You might want to open the supply and have a look at it. A while back I had one that
was wiping out my neighbors AM radio. When I looked inside the rf filter on the ac side
had been omited ! Oh there was a place for a couple of caps and a comon mode inductor
but the caps wern't there and the inductor replaced with 2 jumpers.
  Reply With Quote
Old 16th October 2009, 10:44 PM   #4
diyAudio Member
 
Join Date: Apr 2003
Location: Portland,Oregon
Blog Entries: 4
Send a message via AIM to DigitalJunkie
Quote:
Originally Posted by woody View Post
You might want to open the supply and have a look at it. A while back I had one that
was wiping out my neighbors AM radio. When I looked inside the rf filter on the ac side
had been omited ! Oh there was a place for a couple of caps and a comon mode inductor
but the caps wern't there and the inductor replaced with 2 jumpers.
That is all too common on the cheaper PSU's. I used to see it all the time on the older AT style ones.

Keep in mind that PC's are pretty noisy by nature,you've got high speed square wave signals running all over the place,HDD's and other things randomly reading/writing/whatever,and that can be a noisy nightmare.
  Reply With Quote
Old 17th October 2009, 07:34 PM   #5
diyAudio Member
 
Join Date: Oct 2009
Location: Hamburg
Thank you all for the advice, I will take a quick look inside for missing capacitors, but if they are designed to be missing I wont bother to reverse engineer the circuit, as thats more effort than buying another one to compare, (and my knowledge of Switched mode power supplies not great). Particularly with the optically linked DAC coming.

I did a quick google, and but google was often confused by low physical noise power supplies. I cant help thinking that every ATX power supply maker claims theirs is a low noise design. That said I did find a few users who had found their brand had excessive electrical noise too. So it looks like woody and DigitalJunkie are not the only ones to report this.
  Reply With Quote
Old 20th October 2009, 09:27 PM   #6
diyAudio Member
 
Join Date: Oct 2009
Location: Hamburg
I am still waiting for my DAC to arrive, to remove the ground loop and the nasty RF from my system, it now says a week to wait.

Since I had 2 quad 303 amplifiers I decided to hook them up to biamp. This produced a ground loop, admittedly not as bad as the computer but still annoying.

Since each quad 303 is declaring an earth, I could see my eventual plan on active crossing over my speakers getting harder.
An unmodified quad 303 per channel, I decided to remove the earthing from the circuit boards, This was easy, since the complete amplifier is earthed only through the signal in connection. to the driver boards.

This way the nasty HUM (and RF) on the computer power supply is not sent to the amplifier to amplify and annoy my ears.

I guess the Quads will live for years so would like to make a safer solution, (not that I see much risk) so am thinking on using the earth solution, Rod Elliott (ESP) solution,

Earthing (Grounding) Your Hi-Fi - Tricks and Techniques

Just in case I am lucky enough one day to have kids or sell the amp on, any comments?
  Reply With Quote
Old 31st October 2009, 10:25 PM   #7
diyAudio Member
 
Join Date: Oct 2009
Location: Hamburg
Default My DAC arrived

First the good, sound is much improved over my reference "Creative Labs SB Audigy (rev 04)". Not only this but the optical link makes the ground loop non existent. Now the bad, the DAC I chose (mostly on price) does not mute when it gets no digital signal (and formally had one) so with the computer off and the amp connected to the DAC I get a not overly loud wide band hiss.

Overall, I consider this a very effective solution to my ground loop issues, and the ATX power supply noise. I still haven taken the power supply apart and looked for missing components. I suspect its just designed in such a way that checks out lots of noise, hence my lack of action.
  Reply With Quote
Old 1st November 2009, 01:54 AM   #8
star882 is offline star882  United States
diyAudio Member
 
star882's Avatar
 
Join Date: Mar 2007
Try a better power supply. Check with the overclockers for advice on a good one.
__________________
"Fully on MOSFET = closed switch, Fully off MOSFET = open switch, Half on MOSFET = poor imitation of Tiffany Yep." - also applies to IGBTs!
  Reply With Quote
Old 2nd November 2009, 01:57 AM   #9
diyAudio Member
 
Join Date: Jun 2006
Location: Columbia, MO
I had good luck using 2 12 gauge bare wires hooked as close to the ATX supply as possible to connect the amplifier board. Noise was almost eliminated compared to using one smaller wire on the end of the ATX disc supply cable. I suspect a really heavy ground cable connecting all grounds in the audio system together would be best. Remember that any current flowing on the 12 Volt line must return on the Neutral so the low resistance will decreased the voltage drop signal.
Ted
  Reply With Quote
Old 16th November 2009, 11:15 PM   #10
diyAudio Member
 
Join Date: Oct 2009
Location: Hamburg
Default DAC + alsa + dmix + Linux >= CD quality audio.

Thanks for the suggestions.

The DAC, which effectively removed the ground loop problem, and bypassed the RF noise (~1 Mhz) with an optical cable.

I have now solved the muting issue with the DAC too. The issue caused by the cheap DAC seemed to occur only when sound apps shut down badly, including pulling the optical out while playing music (I dont know the Optical protocol but assume it has a no more music code). This was overcome by using the dmix plugin to alsa (standard linux sound drivers using the standard software mixer), so now when applications shut down badly alsa shuts down without the hiss problem.

That said I may in the future try some of the other options and its good to have them out on this thread in case others have the same issue.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
measuring the noise of a power supply pjpoes Power Supplies 6 31st March 2008 07:19 PM
Filtering out Power Supply Noise zenon Chip Amps 7 2nd November 2006 06:50 PM
power supply low noise GIPIONE Solid State 0 16th April 2005 04:33 PM
RF Noise in Power Supply sandy Tubes / Valves 2 12th January 2005 04:03 PM
power supply noise flux01 Pass Labs 12 9th February 2004 01:42 PM


New To Site? Need Help?

All times are GMT. The time now is 05:42 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2