Reg problem /help! - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th March 2006, 10:49 AM   #1
duffy is offline duffy  New Zealand
diyAudio Member
 
Join Date: Nov 2004
Location: Auckland
Default Reg problem /help!

I'm sure this is a total stupid question, but

I've made simple MOSFET regulator as per:

http://www.passdiy.com/projects/zenv3-2.htm

It's bipolar using IRFP240/IRFP9240 and I am wanting +/-35V regulated. My problem is that my output voltages are the same as my input voltages!

SOURCE 50.6V Bad!
DRAIN 50.6V Good!
GATE 38.8V Good!

I've 10x checked connections and joints, and am sure that it is per diagram (I know I am wrong here!), the only changes are: higher voltage drop which is intended, and that it is driving into snubbed 6800uF caps.

Ideas?
  Reply With Quote
Old 17th March 2006, 10:54 AM   #2
eLarson is offline eLarson  United States
diyAudio Member
 
eLarson's Avatar
 
Join Date: Aug 2002
Location: Gaithersburg, MD
Are you absolutely sure you have the gate, drain and source sorted out?

Do you have any other devices you could substitute?
__________________
Would a woodchuck bother to chuck MDF?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mtx amp problem [[help!!]] fuzzypinkhat45 Car Audio 3 8th July 2008 05:34 AM
CDM 2/29 Problem HELP! Bassivus Digital Source 29 23rd December 2007 10:00 AM
FRD/ZMA Problem Twisted85 Multi-Way 5 4th December 2006 01:19 PM
p3a problem MaXiZ Solid State 17 16th July 2005 07:14 AM


New To Site? Need Help?

All times are GMT. The time now is 05:57 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2