Mini a's Up in SMOKE :eek: - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th October 2005, 02:03 AM   #1
jleaman is offline jleaman  Belgium
Banned
 
Join Date: Apr 2002
Send a message via AIM to jleaman
Default Mini a's Up in SMOKE :eek:

Well we have one channel here up in smoke.

Email :

After several weeks of sounding just fine, the amp decided over the weekend to play bad. I usually leave all my amps running when Iím out of the room for a few minutes or hours, so I canít be sure when it happened, but it wasnít hard to observe the results. Upon returning to the living room, a bubbling crackling noise was discernable from one speaker, along with the unmistakable smell of melted voice coil enamel, and a slight orange glow from under the dust cap of the Fostex drivers. .

One channel of the amp measures full 20V DC at the speaker terminals, with less than .002 on the other side. Itís likely gonna be a few days before I can get to putting in on my bench to pop the top and poke around. I have no idea how to measure anything other than R values Ė have you got any suggestions how to determine which if any of the semiís are toast?

Once repaired, any suggestions on a hi pass output filter or other DC protection circuits? If I keep the amp, I donít want to risk damaging drivers like the AMT Heils, Fostex or CSS full rangers.

Email :


My observations ( no stepping on toes i hope )

One of the fet's have come loose enough that the ceramic pad has moved causing the fet to not disapate the heat into the heat sink.

Or the screw metal has a diferent reaction to metal on metal at a certian tempature causing it to move or expand. That little bit of expansion made the ceramic pad fall the opposite direction of the get.

Would a fet not being properly cooled causse the amplifier to do what ? and cause rail voltage into a speaker ?

I have pictures.

J'
  Reply With Quote
Old 16th October 2005, 04:09 AM   #2
jleaman is offline jleaman  Belgium
Banned
 
Join Date: Apr 2002
Send a message via AIM to jleaman
Pic.
Attached Images
File Type: jpg minia-1.jpg (66.6 KB, 612 views)
  Reply With Quote
Old 16th October 2005, 04:38 AM   #3
diyAudio Member
 
Brian Donaldson's Avatar
 
Join Date: Jan 2003
Location: Texas, Love it or leave it
Here's what happens. If the fet runs too hot from no heat sink goo or too loose screw, etc., the heat cool cycles from turning it off and on cause the silicon to delaminate from the metal base, causing more overheating, then the fet shorts, and you have rail on the speaker. Don't ask me how I know.
  Reply With Quote
Old 16th October 2005, 04:42 AM   #4
jleaman is offline jleaman  Belgium
Banned
 
Join Date: Apr 2002
Send a message via AIM to jleaman
Thanks. .. ill be taking all these parts off the board or ill see if we can get him a new board..

J'
  Reply With Quote
Old 16th October 2005, 04:52 AM   #5
azira is offline azira  United States
diyAudio Member
 
Join Date: Dec 2003
Location: Near Seattle
Hope you don't mind me asking an unrelated question... How do you like those SIL pads inplace of thermal goop? I have quite a few of them around and I can't decide how well/poor they work.
--
Danny
  Reply With Quote
Old 16th October 2005, 04:59 AM   #6
jleaman is offline jleaman  Belgium
Banned
 
Join Date: Apr 2002
Send a message via AIM to jleaman
Quote:
Originally posted by azira
Hope you don't mind me asking an unrelated question... How do you like those SIL pads inplace of thermal goop? I have quite a few of them around and I can't decide how well/poor they work.
--
Danny
Me i love them but they do have to be tightened down..

My idea.. >
Attached Images
File Type: jpg fet bolt.jpg (13.6 KB, 447 views)
  Reply With Quote
Old 16th October 2005, 05:08 AM   #7
diyAudio Member
 
mpmarino's Avatar
 
Join Date: Jun 2004
Location: Crunchville, where I don't fit in.
That stinks J',

I'd bet that only that 1 fet is toast (well, and the speaker of course). I have never been comfortable with mounting a fet with a single screw like that. I pretty much always use a piece of 1/2" alu bar stock across the fet with 2 stainless hex machine screws straddling the fet. Boy you can really crank down on 'em with much less risk of damaging the device and the risk if loosening is minimised. Also, the bolt feels less heat so perhaps it won't expand/change as much. Using that method I have noticed VERY little difference between device temp and sink temp probing around with an IR thermometer (maybe 3 or 4 C) and I think sink contact is way better. Just a suggestion.....


WOW!!! you posted as I was typing...COOL!
__________________
Crazy Yankee.
  Reply With Quote
Old 16th October 2005, 05:20 AM   #8
fcel is offline fcel  United States
diyAudio Member
 
Join Date: Sep 2001
Location: LA County
Jason,
Schematic says plus and minus 15V rail. I remembered you saying that you are using 22V rail. Could that be the reason why you fried the MOSFET?
  Reply With Quote
Old 16th October 2005, 05:25 AM   #9
jleaman is offline jleaman  Belgium
Banned
 
Join Date: Apr 2002
Send a message via AIM to jleaman
Quote:
Originally posted by fcel
Jason,
Schematic says plus and minus 15V rail. I remembered you saying that you are using 22V rail. Could that be the reason why you fried the MOSFET?

This was not my amp.. and mine are running at 20V rails witch will not hurt it at all. Just have to have the heat sink to cool it.. I think the main reason for this smoke show was due to heat not being transfered from the fet to heat sink..


J'
  Reply With Quote
Old 16th October 2005, 05:34 AM   #10
fcel is offline fcel  United States
diyAudio Member
 
Join Date: Sep 2001
Location: LA County
Not your amp? Now I know why post #1 looks kind of "odd" ....
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MINI A: who let the smoke out. d to the g Pass Labs 9 28th March 2009 03:32 PM
Zen V4 smoke.... rebojorge Pass Labs 8 20th December 2007 09:34 PM
T-amp up in smoke jwb009 Class D 21 4th April 2006 07:50 AM
I let the smoke out. TerryG Class D 16 8th November 2005 07:25 PM
Up in smoke... PhaseShift Solid State 2 3rd September 2002 06:03 PM


New To Site? Need Help?

All times are GMT. The time now is 04:54 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2