diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Pass Labs (http://www.diyaudio.com/forums/pass-labs/)
-   -   Please help with aleph p 1.7 volume relay pops and click (http://www.diyaudio.com/forums/pass-labs/38522-please-help-aleph-p-1-7-volume-relay-pops-click.html)

ostemaden 27th July 2004 01:59 PM

Please help with aleph p 1.7 volume relay pops and click
 
Help

I am at the moment building an aleph p 1.7 preamp, and I am having problems with the volume relays.

When the volume goes from step 191 (10111111) to step 192 (11000000) I get pops and clicks in my power amplifier.

I can't determine if the pops and clicks are made by current interference due to the relays coils being turned off/on or if the pops and clicks are made by the in/out switching of almost every resistor in the volume circuit

Please give me some advice to solve this problem :confused:

Best regards
Ostemaden

Holger Barske 27th July 2004 03:15 PM

This is very common problem with relay attenuators, as you have seven relais switching at once and some unwanted settings may occur for a very short time, enough to cause that popping noise.
The "brute force" solution would be to mute the volume control very shortly before this condition occurs and turning it on again when the relais have settled.

ostemaden 27th July 2004 03:45 PM

Thank you for answering and you are quite right, I have tried some different things and the best so far is to mute for approx. 400 us before changing the volume settings.

There is still a little bit of clicks and pops, but it is much better than before.

Thank you for helping :)

Ostemaden


All times are GMT. The time now is 04:28 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2