can I replace ztx450 to bc 550 in ZenV4 - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th June 2004, 08:18 AM   #1
diyAudio Member
 
elviukai's Avatar
 
Join Date: Apr 2003
Location: EU- Electronic Union country
Default can I replace ztx450 to bc 550 in ZenV4

I searched everywhere, no letf in whole country

I tryed bc 639, but R0 blown and fets too.. ( I put legs right, no mistake- have change legs because ztx 450 and bc 639 has diferent)

any help? what n chanel transistor I should use? I was thinking that any npn device but now I see its wrong.

24 mosfet are already dead, as a 12 RO (o,47om)

__________________
natural sound reproduction from traditional dynamic drivers?!! come on.. no no, it can be.. it must be!..
  Reply With Quote
Old 8th June 2004, 08:34 AM   #2
diyAudio Member
 
Join Date: Mar 2002
you can use any ordinary NPN, i used bc 546, 548, 550 and
ztx 653 (more power than 450). your problem shouldn't be this transistor.
  Reply With Quote
Old 8th June 2004, 08:47 AM   #3
Banned
 
Join Date: Apr 2002
Location: Germany, Clausthal
My Zen V4 runs with BC550 without problem.

You have another problem.

Try to run the amp with less bias first / make R0 not to small first. Try 1A or so.

Double check all pins and connections of Transistors and FETs.

Make good connection short wires to power supply.

If does not work: Test the regulator alone first, the test the amp with the aleph current source modulation resistor disconnected.
  Reply With Quote
Old 8th June 2004, 08:49 AM   #4
diyAudio Member
 
elviukai's Avatar
 
Join Date: Apr 2003
Location: EU- Electronic Union country
very srange.. because I have only one ztx 450. and both chanels work great wih this one, I do only one thing- resolder ztx 450 and solder in its place bc 693. rezult was obviuos - r0 down ..
__________________
natural sound reproduction from traditional dynamic drivers?!! come on.. no no, it can be.. it must be!..
  Reply With Quote
Old 8th June 2004, 10:21 AM   #5
diyAudio Member
 
Join Date: Mar 2002
strange, yes. as you connected it correctly, maybe your bc639 is bad?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ZTX450 vs BC637 gionag Pass Labs 3 29th April 2008 03:12 PM
Sub for NTE128P for ZTX450 Aleph 30 john65b Pass Labs 4 11th December 2007 06:55 PM
WTB: ztx450, 2SK117, 2SK30 genome Swap Meet 0 17th March 2005 01:19 AM
ZTX450 for AX kilowattski Pass Labs 7 29th October 2004 03:28 PM
ZTX450 Alternative from the BC... range? konstantin Pass Labs 9 3rd February 2003 09:14 PM


New To Site? Need Help?

All times are GMT. The time now is 06:18 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2