not giving up on the SOZ - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th May 2004, 03:25 PM   #1
diyAudio Member
 
MEGA_amp's Avatar
 
Join Date: Oct 2003
Location: CT
Default not giving up on the SOZ

I recently purchased rather large heatsinks from CTR surplus, I have 2 measured at 21" x 15" 1/2" base 3" high fins. They are massive and very heavy, they were used to cool a 9kVA unit from a company called Analogic Corporation. With my Aleph 2 on hold, i wanted to give a hack at the SOZ again. I also purchased surplus some Dale Aluminum power resistors: 6 50W 1 ohm, and will be purchasing 8 Dale 250 watters. I'm aiming at 25-30 watts out. This is the power supply for one channel I plan to use, just checking to see if its correct. Particularly the xformer config.

Many Thanks,

JH
Attached Images
File Type: gif power supply 30w soz sm2.gif (29.3 KB, 319 views)
  Reply With Quote
Old 19th May 2004, 05:16 PM   #2
diyAudio Member
 
Alain Dupont's Avatar
 
Join Date: Sep 2003
Location: Paris - France
MEGA-amp,

You transformer wiring seams correct.

Regards.

Alain.
  Reply With Quote
Old 19th May 2004, 06:24 PM   #3
moe29 is offline moe29  United States
diyAudio Member
 
moe29's Avatar
 
Join Date: Dec 2002
Location: Florida
Send a message via AIM to moe29 Send a message via Yahoo to moe29
Be sure to use some type of inrush current protection... you've
got a lot of uF's in the PSU
  Reply With Quote
Old 19th May 2004, 07:33 PM   #4
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
MuuuHahahahaha
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TV PSU giving me nightmares Archimedes Analogue Source 11 26th August 2009 09:59 PM
Turntable giving out too much treble. thelostpatrol Analogue Source 2 5th April 2007 12:49 AM
my SY CCS is only giving me 15mA Shoog Tubes / Valves 17 6th March 2006 06:43 PM
Giving them the horn? JRKO Multi-Way 7 3rd July 2004 04:49 PM


New To Site? Need Help?

All times are GMT. The time now is 11:37 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2