diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Pass Labs (http://www.diyaudio.com/forums/pass-labs/)
-   -   please HELP bourned Source resistor Aleph 30 (http://www.diyaudio.com/forums/pass-labs/32018-please-help-bourned-source-resistor-aleph-30-a.html)

wijgers 11th April 2004 10:40 AM

please HELP bourned Source resistor Aleph 30
 
Hello,

Just applied 20V rails and burned two Source resistors.

The two resistors are conected at the negative rails, and burned within 10 sec.

Voltage is +- 21.4 V
There was no input conected
There was a 30 W 8 ohm resistor at the output.

Please help what could be wrong???????

Nils

MikeW 11th April 2004 02:11 PM

Short
 
You have a short. Check all transistors. Run the amp without a load. Most problems I have had are with the 9610's. I have a few extra if you need some.

Dennis Hui 11th April 2004 02:27 PM

Don't forget to check the NPN transistors and
make sure they're in the right way.

Good luck.

Dennis

wijgers 12th April 2004 08:35 PM

Found it!!!
 
Thanks for the replies, But It was me who made the mistake.

By mistake and uncarefull checking, I didn't conect R 18 to the colector of the current source MPSA18.

After a good check, I did another try, And it worked. No failures any more.

Listened to it I was Clear it make a defference. More AIR, very detailed, en bright.

So next thing to do is make a PRE and build a case for the Aleph 30.

Thanks again.

Nils


All times are GMT. The time now is 06:10 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2