General Question/Old Threshold Equipment - Page 3 - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th October 2012, 09:35 AM   #21
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
pics , please
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 7th October 2012, 01:12 PM   #22
Jolida is offline Jolida  India
diyAudio Member
 
Join Date: Jan 2012
Location: South India
Sorry. I just found out it had got to do with the pre-amp. But as the amp was playing the front panel LED lights have switched them self off. Tried switching off the amp & switching on, but the LED do not function. The amp works fine though. Behind the amp there are Fuses named Output & Rail Fuse. Anything to be looked upon here ?
  Reply With Quote
Old 7th October 2012, 02:26 PM   #23
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
regular re-cap,thorough checking of all solder joints,change of all suspicious parts ......

without pics we can't help in pinpoint any of these

if you aren't able to give us what's needed to help and guide you , then better leave that job to someone experienced
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 7th October 2012, 05:05 PM   #24
Jolida is offline Jolida  India
diyAudio Member
 
Join Date: Jan 2012
Location: South India
I sure can do that. Do u want me to post the internal pics of the amp??
  Reply With Quote
Old 7th October 2012, 05:33 PM   #25
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
more , the merrier
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 22nd October 2012, 07:46 PM   #26
Jolida is offline Jolida  India
diyAudio Member
 
Join Date: Jan 2012
Location: South India
Quote:
Originally Posted by Zen Mod View Post
more , the merrier
I bought a new pre amp & the distortion is gone. But one thing remains. There is a Hum in both channels of the power amp regardless of the input being connected or not. Please help..
  Reply With Quote
Old 22nd October 2012, 07:59 PM   #27
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
Quote:
Originally Posted by Zen Mod View Post
regular re-cap,thorough checking of all solder joints,change of all suspicious parts ......

without pics we can't help in pinpoint any of these

if you aren't able to give us what's needed to help and guide you , then better leave that job to someone experienced
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 22nd October 2012, 08:19 PM   #28
Jolida is offline Jolida  India
diyAudio Member
 
Join Date: Jan 2012
Location: South India
https://www.dropbox.com/sh/yal9w15nw9544yl/ZMNbM32a0C
  Reply With Quote
Old 22nd October 2012, 08:33 PM   #29
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
thank you

all I can do is to repeat what I wrote already - regular re-cap,thorough checking of all solder joints,change of all suspicious parts ........

and - as I can see , there are more than few suspicious resistors , which means that some active parts are suspicious too

so , considering both value and complexity of amp , that's job for someone skilled

that's probably least painful and least expensive way
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chip Amp General Question bluetech Chip Amps 18 16th January 2009 11:38 PM
General question about Sound Cards davidlzimmer Digital Source 4 24th March 2007 04:26 AM
2 general gainclone questions, and an lm1875 question Adam M. Chip Amps 11 4th March 2005 12:53 PM
Few general question for starter? tomchaoda Tubes / Valves 8 4th November 2004 06:23 AM
General Amp Question RobPhill33 Solid State 8 21st January 2003 03:34 PM


New To Site? Need Help?

All times are GMT. The time now is 10:37 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2