Forte 1a left channel buzz - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 10th March 2013, 10:36 PM   #11
diyAudio Member
jacco vermeulen's Avatar
Join Date: Oct 2004
Location: At the sea front, Rotterdam or Curaçao
Send a message via Yahoo to jacco vermeulen
Originally Posted by Les Berkley View Post
good current options?
Digikey, try Cornell Dubilier (CDE)

In that uF size, with screw terminals, likely have to pick 50Vdc ones.
Go for CGS types (Computer Grade special, Screw me)
They're actually the same Mallory CGS's, which Poah used in his Dark&Hairy days.
Hasi bo best

Last edited by jacco vermeulen; 10th March 2013 at 10:41 PM.
  Reply With Quote
Old 11th March 2013, 12:00 AM   #12
diyAudio Member
Join Date: Mar 2013
Location: Pottstown
Will post some pictures tomorrow.
  Reply With Quote
Old 29th May 2015, 08:09 PM   #13
HWM is offline HWM
diyAudio Member
Join Date: Mar 2013
I know I'm waaay late to this party, but I too have a Forte (Model 3) that I've replaced the PS caps and the 2 yellow film caps. That's all. It was dead quiet before the change, now there's a slight buzz on the left channel. I'm not a pro, but did check solder points and everthing seems solid. I can't figure out why it's buzzing? It also buzzes without any inputs hooked up, so it shouldn't be a ground loop issue. As I noted, the buzz is barely there and the amp sounds great, but it's driving me nuts. Any insights? Thanks.
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Adcom GFA-555 Left Channel Buzz Dudeman258 Pass Labs 18 14th March 2013 01:25 PM
Forte 1a hooch2259 Pass Labs 4 8th February 2013 12:26 AM
Adcom GFA-555 Left Channel Buzz Help Dudeman258 Solid State 0 6th May 2011 08:29 PM
NAD 310 buzz in left channel Rodmunch Solid State 2 21st March 2009 11:58 PM
Forté 1A - buzz problem!!! lukesound Pass Labs 3 20th February 2009 09:43 AM

New To Site? Need Help?

All times are GMT. The time now is 05:44 PM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright ©1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2