De-Lite strange problem - Page 3 - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th July 2012, 04:59 PM   #21
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
Given that you are having problems, you would want Fig. 10, assuming that
you are using a depletion mode part.

Also given that you are having problems, perhaps you should insert a 100
ohm or so resistor in series with the Gate of the Mosfet.

The idea that it works with one source and not another is quite suspicious.

Measure some of the DC voltages for us.


Last edited by Nelson Pass; 25th July 2012 at 05:03 PM.
  Reply With Quote
Old 25th July 2012, 05:23 PM   #22
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
I think I have solved my problems. It was ZenMod who caused some doubt.

Nelson. What I don't understand is :-

I have built the amp as per Fig 5. This suggests that this is an "improved" version of the first iteration. Fig 10 is an "icing on the cake" working (as far as I can see and suggested that this equals a 300B amp).

Are you saying that unless I build as per Fig 10 I am wasting my time?

I am using 20N FETS. I am pretty sure that the circuit is NOW working correctly. I will measure the DC voltages.

Rob.
  Reply With Quote
Old 25th July 2012, 07:40 PM   #23
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
If the "Improved" example biases up properly, you're good to go.

  Reply With Quote
Old 25th July 2012, 07:52 PM   #24
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
Quote:
Originally Posted by Nelson Pass View Post
If the "Improved" example biases up properly, you're good to go.

OK. Will report back in the next few days. Thanks for your help.

Rob.
  Reply With Quote
Old 26th July 2012, 02:52 AM   #25
diyAudio Member
 
Join Date: Oct 2011
Hi Nelson, what do you think about my latest circuit(sorry about the lousy schematic drawing) which has been built and works incredibly well with two way large horns.

Any idea on output power?
Attached Images
File Type: png sch_ZCA.png (50.5 KB, 77 views)
  Reply With Quote
Old 29th July 2012, 10:27 AM   #26
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
Ta Da!!! It is done (apart from a very slight mains hum) will increase the PS caps.

Now to tidy and pretty it up.

Click the image to open in full size.

Click the image to open in full size.
  Reply With Quote
Old 2nd August 2012, 10:39 AM   #27
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
I am still having hum problems. Would this amp benefit from a split rail supply as per the
F5?
  Reply With Quote
Old 2nd August 2012, 10:48 AM   #28
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
caps are too far from active circ

put them in same box
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 2nd August 2012, 10:54 AM   #29
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
Put the PS cap banks close to the power amp circuit?

What about split rail? I have all grounds in with -volts?
  Reply With Quote
Old 2nd August 2012, 11:03 AM   #30
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
Quote:
Originally Posted by Puffin View Post
Put the PS cap banks close to the power amp circuit?
....
conditio sine qua non , besides proper wiring scheme

Quote:
Originally Posted by Puffin View Post
.....

What about split rail?....
in your case , thats of secondary importance


Quote:
Originally Posted by Puffin View Post
.....I have all grounds in with -volts?

clarify
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
De-Lite grounding Puffin Pass Labs 35 5th July 2012 05:58 PM
De-Lite Amplifier Nelson Pass diyAudio.com Articles 35 3rd June 2012 08:37 PM
de-lite mosfets ixth6n50d2 bjcwolters Parts 0 3rd August 2011 10:40 AM
Hoping somebody can help with De-Lite build? cddeluca Pass Labs 3 11th July 2010 02:14 AM
Snow De-Lite skidave Pass Labs 12 12th February 2010 06:35 PM


New To Site? Need Help?

All times are GMT. The time now is 07:24 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2