F5 problems - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th April 2012, 10:39 PM   #11
diyAudio Member
 
Join Date: Oct 2001
Location: Sweden
Send a message via MSN to Flemming J P
I was one of the mosfet that had died
  Reply With Quote
Old 12th April 2012, 02:36 AM   #12
diyAudio Member
 
Join Date: Dec 2005
Location: São Paulo
Do you have an idea why?
  Reply With Quote
Old 12th April 2012, 02:56 PM   #13
diyAudio Member
 
Join Date: Oct 2001
Location: Sweden
Send a message via MSN to Flemming J P
No clue. When I turned the amp off, I head a pop in one speaker. The next time I tried to turn on the amp, it smoked (very hot resistors).

I ran the mosfets at 750 ma each at 32 v rails (350mv drop over 0.5 ohm source resistors).

I have chosen to run with lower bias (600 ma) after measuring how much or rather little power I actually use even when I play loud.
  Reply With Quote
Old 12th April 2012, 03:09 PM   #14
diyAudio Member
 
KatieandDad's Avatar
 
Join Date: Nov 2011
Location: UK
This thread started with you suspecting the input JFets. Have you now discovered that one of the power MOS-FETs has failed ?

The MOS-FETs can fail for a number of reasons.

However, the most likely is a short in the speaker leads, OR, overheating, OR, a foreign object shoprting MOS-FET to heatsink.
  Reply With Quote
Old 12th April 2012, 06:52 PM   #15
diyAudio Member
 
Join Date: Oct 2001
Location: Sweden
Send a message via MSN to Flemming J P
I thought it was the input fets, due to the fact that it was the feedback resistors that got hot/smoked (that was after I had turned the bias down to 0).

After some measurements I found that one of the mosfets was conduction at full power all the time no mater what.
  Reply With Quote
Old 14th April 2012, 01:37 AM   #16
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
It happens occasionally.

  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
F5 turbo problems Rob Dingen Pass Labs 17 11th January 2013 08:38 PM
1M-F5 - A 1 MHz F5 project triode_al Pass Labs 43 25th October 2012 08:28 AM
F5 Amps - Building a Quartet of Amps in search of the Ultimate F5 NYCOne Pass Labs 123 29th September 2011 12:04 AM
F5 Cascoded - an alternative for my interest in the Balanced F5 NYCOne Pass Labs 159 24th March 2011 05:23 AM
MiniWatt N3 problems, oscillation thumping and RF/motor problems. Destroyer OS. Tubes / Valves 18 6th July 2010 12:14 AM


New To Site? Need Help?

All times are GMT. The time now is 03:57 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2